summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnish2020-07-12 12:55:22 +0100
committerAnish2020-07-12 12:55:22 +0100
commit0dc81ef0489c13a2aa158560aa08951db8ce067a (patch)
tree0fe8f38c884a8a9ea6c7370e799e72a646c9b41e
downloadaur-0dc81ef0489c13a2aa158560aa08951db8ce067a.tar.gz
Initial Push
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD43
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e573a8dae7c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = dmenu-supermario9590-git
+ pkgdesc = This is my personal build of dmenu that is patched for fonts, centering, borders, etc.
+ pkgver = 4.9.r572.9b38fda
+ pkgrel = 1
+ url = https://www.github.com/supermario9590/dmenu-supermario9590.git
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ provides = dmenu
+ conflicts = dmenu
+ source = git+https://www.github.com/supermario9590/dmenu-supermario9590.git
+ md5sums = SKIP
+
+pkgname = dmenu-supermario9590-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..946628097337
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+pkgname=dmenu-supermario9590-git
+pkgver=4.9.r572.9b38fda
+pkgrel=1
+epoch=
+pkgdesc="This is my personal build of dmenu that is patched for fonts, centering, borders, etc."
+arch=(x86_64 i686)
+url="https://www.github.com/supermario9590/dmenu-supermario9590.git"
+license=('MIT')
+groups=()
+depends=()
+makedepends=(git)
+checkdepends=()
+optdepends=()
+provides=(dmenu)
+conflicts=(dmenu)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "4.9.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ }
+
+ build() {
+ cd dmenu-supermario9590
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+ }
+
+ package() {
+ cd dmenu-supermario9590
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ cp -rf * ${pkgdir}/opt/${pkgname}
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ }
+