summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSuper Mario2020-10-13 20:45:12 +0000
committerSuper Mario2020-10-13 20:45:12 +0000
commita022ffe260176730aaeb47b1c201b0bb6dfed114 (patch)
tree8b4c6406ca1a15fcad0b73ddd96aafbc88719d97
parentb364e746fc5de6e672b2d3d40128238846f74a66 (diff)
downloadaur-a022ffe260176730aaeb47b1c201b0bb6dfed114.tar.gz
Restructured
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD35
-rw-r--r--dmenu-supermario9590.diff33
3 files changed, 55 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5db71fdf388e..9be97fb70910 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = dmenu-supermario9590-git
pkgdesc = My custom build of suckless' dmenu
- pkgver = r576.26e2309
+ pkgver = r573.1a13d04
pkgrel = 1
- url = https://gitlab.com/supermario9590/dmenu-supermario9590.git
+ url = gitlab.com/supermario9590/dmenu-supermario9590.git
arch = i686
arch = x86_64
license = MIT
@@ -11,7 +11,7 @@ pkgbase = dmenu-supermario9590-git
depends = ttf-symbola
provides = dwm
conflicts = dwm
- source = git+https://gitlab.com/supermario9590/dmenu-supermario9590.git
+ source = dwm::git+http://git.suckless.org/dmenu
md5sums = SKIP
pkgname = dmenu-supermario9590-git
diff --git a/PKGBUILD b/PKGBUILD
index 76a7bd1cc75f..63dd1a441cc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,25 +6,25 @@
# The following guidelines are specific to BZR, GIT, HG and SVN packages.
# Other VCS sources are not natively supported by makepkg yet.
-# Maintainer: Your Name <youremail@domain.com>
-pkgname=dmenu-supermario9590-git # '-bzr', '-git', '-hg' or '-svn'
-pkgname_=dmenu-supermario9590
-pkgver=r576.26e2309
+# Maintainer: Anish Vundela <anishreddyvundela@gmail.com>
+pkgname=dmenu-supermario9590-git
+_pkgname=dwm
+pkgver=r573.1a13d04
pkgrel=1
pkgdesc="My custom build of suckless' dmenu"
-arch=('i686' 'x86_64')
-url="https://gitlab.com/supermario9590/dmenu-supermario9590.git"
+arch=(i686 x86_64)
+url="gitlab.com/supermario9590/dmenu-supermario9590.git"
license=('MIT')
groups=()
depends=(nerd-fonts-mononoki ttf-symbola)
-makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
-provides=("dwm")
-conflicts=("dwm")
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
replaces=()
backup=()
options=()
install=
-source=("git+$url")
+source=('dwm::git+http://git.suckless.org/dmenu')
noextract=()
md5sums=('SKIP')
@@ -32,18 +32,21 @@ md5sums=('SKIP')
# a description of each element in the source array.
pkgver() {
- cd "$srcdir/${pkgname_}"
+ cd "$srcdir/$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/$_pkgname"
+ patch -p1 -i ../../dmenu-supermario9590.diff
+}
+
build() {
- cd "$srcdir/${pkgname_}"
+ cd "$srcdir/$_pkgname"
make
}
package() {
- cd "$srcdir/${pkgname_}"
- make PREFIX=/usr DESTDIR="$pkgdir/" install
- install -Dm644 LICENSE $pkgdir/usr/share/licences/$pkgname/LICENCE
- install -Dm644 README.md $pkgdir/usr/share/doc/$pkgname/README.md
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
}
diff --git a/dmenu-supermario9590.diff b/dmenu-supermario9590.diff
new file mode 100644
index 000000000000..11d7ffd5230f
--- /dev/null
+++ b/dmenu-supermario9590.diff
@@ -0,0 +1,33 @@
+From f44d8d8d05a16d70fed6b4a91ddea0019ad0da70 Mon Sep 17 00:00:00 2001
+From: Super Mario <anishreddyvundela@gmail.com>
+Date: Tue, 13 Oct 2020 19:38:57 +0000
+Subject: [PATCH] Made patch for my build
+
+---
+ config.def.h | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/config.def.h b/config.def.h
+index 1edb647..3dc0f62 100644
+--- a/config.def.h
++++ b/config.def.h
+@@ -4,13 +4,13 @@
+ static int topbar = 1; /* -b option; if 0, dmenu appears at bottom */
+ /* -fn option overrides fonts[0]; default X11 font or font set */
+ static const char *fonts[] = {
+- "monospace:size=10"
++ "Mononoki Nerd Font:size=10"
+ };
+ static const char *prompt = NULL; /* -p option; prompt to the left of input field */
+ static const char *colors[SchemeLast][2] = {
+ /* fg bg */
+- [SchemeNorm] = { "#bbbbbb", "#222222" },
+- [SchemeSel] = { "#eeeeee", "#005577" },
++ [SchemeNorm] = { "#f8f8f2", "#282a36" },
++ [SchemeSel] = { "#000000", "#ff79c6" },
+ [SchemeOut] = { "#000000", "#00ffff" },
+ };
+ /* -l option; if nonzero, dmenu uses vertical list with given number of lines */
+--
+2.28.0
+