summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnish Vundela2020-09-26 07:39:04 +0100
committerAnish Vundela2020-09-26 07:39:04 +0100
commitb364e746fc5de6e672b2d3d40128238846f74a66 (patch)
tree2712f23c0c62185226649c0a78844c2c33a72ea2
parent9dcd32b63a566969d202333e84af671cf349ff24 (diff)
downloadaur-b364e746fc5de6e672b2d3d40128238846f74a66.tar.gz
Initial Push
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD64
2 files changed, 44 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index baaddc1dd31a..5db71fdf388e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = dmenu-supermario9590-git
- pkgdesc = This is my personal build of dmenu that is patched for fonts, centering, borders, etc.
- pkgver = 4.9.r572.9b38fda
+ pkgdesc = My custom build of suckless' dmenu
+ pkgver = r576.26e2309
pkgrel = 1
- url = https://www.gitlab.com/supermario9590/dmenu-supermario9590.git
- arch = x86_64
+ url = https://gitlab.com/supermario9590/dmenu-supermario9590.git
arch = i686
+ arch = x86_64
license = MIT
makedepends = git
- provides = dmenu
- conflicts = dmenu
- source = git+https://www.gitlab.com/supermario9590/dmenu-supermario9590.git
+ depends = nerd-fonts-mononoki
+ depends = ttf-symbola
+ provides = dwm
+ conflicts = dwm
+ source = git+https://gitlab.com/supermario9590/dmenu-supermario9590.git
md5sums = SKIP
pkgname = dmenu-supermario9590-git
diff --git a/PKGBUILD b/PKGBUILD
index d7ae040b94fa..76a7bd1cc75f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,49 @@
-pkgname=dmenu-supermario9590-git
-pkgver=4.9.r572.9b38fda
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=dmenu-supermario9590-git # '-bzr', '-git', '-hg' or '-svn'
+pkgname_=dmenu-supermario9590
+pkgver=r576.26e2309
pkgrel=1
-epoch=
-pkgdesc="This is my personal build of dmenu that is patched for fonts, centering, borders, etc."
-arch=(x86_64 i686)
-url="https://www.gitlab.com/supermario9590/dmenu-supermario9590.git"
+pkgdesc="My custom build of suckless' dmenu"
+arch=('i686' 'x86_64')
+url="https://gitlab.com/supermario9590/dmenu-supermario9590.git"
license=('MIT')
groups=()
-depends=()
-makedepends=(git)
-checkdepends=()
-optdepends=()
-provides=(dmenu)
-conflicts=(dmenu)
+depends=(nerd-fonts-mononoki ttf-symbola)
+makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("dwm")
+conflicts=("dwm")
replaces=()
backup=()
options=()
install=
-changelog=
source=("git+$url")
noextract=()
md5sums=('SKIP')
-validpgpkeys=()
-pkgver() {
- cd "${_pkgname}"
- printf "4.9.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- }
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
- build() {
- cd dmenu-supermario9590
- make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
- }
+pkgver() {
+ cd "$srcdir/${pkgname_}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
- package() {
- cd dmenu-supermario9590
- mkdir -p ${pkgdir}/opt/${pkgname}
- cp -rf * ${pkgdir}/opt/${pkgname}
- make PREFIX=/usr DESTDIR="${pkgdir}" install
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- }
+build() {
+ cd "$srcdir/${pkgname_}"
+ make
+}
+package() {
+ cd "$srcdir/${pkgname_}"
+ make PREFIX=/usr DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE $pkgdir/usr/share/licences/$pkgname/LICENCE
+ install -Dm644 README.md $pkgdir/usr/share/doc/$pkgname/README.md
+}