summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Depau2019-08-14 12:35:31 +0200
committerDavide Depau2019-08-14 12:35:31 +0200
commitda1db0d23676032f9ae365250c79c96b3813fb8b (patch)
treec4e8a85302a205f6099f35283960f56283a04f2a
parent9d48636bc0c6199163ac3dc1f3fa80234baaed8f (diff)
downloadaur-da1db0d23676032f9ae365250c79c96b3813fb8b.tar.gz
Make dmenu-wl provide dmenu
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index beb3c880f550..b55762f7a2ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dmenu-wayland-git
pkgdesc = Wayland port of a generic menu for X
- pkgver = 4.2.1.r34.88f1766
+ pkgver = 4.2.1.r40.b76d594
pkgrel = 1
url = https://github.com/nyyManni/dmenu-wayland
arch = i686
@@ -15,7 +15,9 @@ pkgbase = dmenu-wayland-git
depends = libxkbcommon
depends = glib2
provides = dmenu-wayland
+ provides = dmenu
conflicts = dmenu-wayland
+ conflicts = dmenu
source = git+https://github.com/nyyManni/dmenu-wayland.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b7937b40de5a..9a2a98a794d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname=dmenu-wayland
pkgname=$_pkgname-git
-pkgver=4.2.1.r34.88f1766
+pkgver=4.2.1.r40.b76d594
pkgrel=1
pkgdesc="Wayland port of a generic menu for X"
url="https://github.com/nyyManni/dmenu-wayland"
@@ -18,8 +18,8 @@ license=('MIT')
depends=('wayland-protocols' 'cairo' 'pango' 'libxkbcommon' 'glib2')
makedepends=('git' 'meson' 'ninja')
# Not providing "dmenu" is intented: it does not provide a "dmenu" command, it's "dmenu-wl"
-provides=(dmenu-wayland)
-conflicts=(dmenu-wayland)
+provides=(dmenu-wayland dmenu)
+conflicts=(dmenu-wayland dmenu)
source=(git+https://github.com/nyyManni/dmenu-wayland.git)
sha256sums=('SKIP')
@@ -51,4 +51,11 @@ package() {
cd $_pkgname
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ msg2 "Installing symlinks for dmenu..."
+ # Install symlinks to provide dmenu
+ ln -sf "dmenu-wl" "$pkgdir/usr/bin/dmenu"
+ ln -sf "dmenu-wl_run" "$pkgdir/usr/bin/dmenu_run"
+ ln -sf "dmenu-wl_path" "$pkgdir/usr/bin/dmenu_path"
+ ln -sf "dmenu-wl.1.gz" "$pkgdir/usr/share/man/man1/dmenu.1.gz"
}