summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMGislv2022-09-09 02:09:20 +0200
committerMGislv2022-09-09 02:09:20 +0200
commitc5da0821e214891e8f173c804e10c0f876fca432 (patch)
tree3b385818bd2547c24ccf91a59d049ab20c961513
parent576db041aaa81553188d531e8b5e04cad9dcf825 (diff)
downloadaur-c5da0821e214891e8f173c804e10c0f876fca432.tar.gz
Qt6 rebuild
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ad45690d26c..47ed7e6a8be8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = dmidiplayer
pkgdesc = MIDI file player based on Drumstick
pkgver = 1.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://dmidiplayer.sourceforge.io/
arch = x86_64
license = GPL3
makedepends = cmake
- makedepends = qt5-tools
+ makedepends = qt6-tools
makedepends = pandoc
+ depends = hicolor-icon-theme
depends = drumstick
depends = uchardet
+ depends = qt6-base
+ depends = qt6-5compat
source = https://downloads.sourceforge.net/dmidiplayer/dmidiplayer-1.7.0.tar.gz
sha512sums = 3778a29de8660b21dff7534595afd69d7e8bcac3a6e4b390986b44c19725ff3a956f679742cade53d78b4a8254341d5ac57e61722b2428c3e63ca316e9c7fb7e
diff --git a/PKGBUILD b/PKGBUILD
index 58d9ae017f9c..234c4e800da3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=dmidiplayer
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='MIDI file player based on Drumstick'
arch=(x86_64)
url='https://dmidiplayer.sourceforge.io/'
license=(GPL3)
-depends=(drumstick uchardet)
-makedepends=(cmake qt5-tools pandoc)
+depends=(hicolor-icon-theme drumstick uchardet qt6-base qt6-5compat)
+makedepends=(cmake qt6-tools pandoc)
source=(https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
sha512sums=(3778a29de8660b21dff7534595afd69d7e8bcac3a6e4b390986b44c19725ff3a956f679742cade53d78b4a8254341d5ac57e61722b2428c3e63ca316e9c7fb7e)
#options=(debug)
@@ -20,11 +20,13 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_DOCS=ON \
- -DUSE_QT=5
+ -DUSE_QT=6 \
+ -Wno-dev
make -C build
}
package() {
make DESTDIR="$pkgdir" -C build install
install -Dm644 $pkgname-$pkgver/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 $pkgname-$pkgver/{ChangeLog,README.md} -t "$pkgdir/usr/share/doc/$pkgname/"
}