summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Taylor2021-05-03 10:00:43 -0500
committerDerek Taylor2021-05-03 10:00:43 -0500
commitdc1cb8ccc8bf7c1402042be998005c49ceac7255 (patch)
treeb9262a31fa5e1fd02627592f2b4e798c3dc1d112
parente030a567b8a09c61dbd5af5495a096635408119f (diff)
downloadaur-dc1cb8ccc8bf7c1402042be998005c49ceac7255.tar.gz
Updating PKGBUILD.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 15 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d4bd974363a..d5798b995c55 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
pkgbase = dmscripts-git
pkgdesc = A collection of dmenu scripts
- pkgver = 1.0.r176.2a03557
+ pkgver = 1.0.r218.3c86c1f
pkgrel = 1
url = https://gitlab.com/dwt1/dmscripts.git
arch = any
license = GPL3
+ makedepends = pandoc
+ makedepends = git
depends = dmenu
depends = ffmpeg
depends = findutils
depends = xclip
depends = xdotool
depends = xorg-xrandr
+ depends = bind
+ depends = jq
optdepends = emacs: editor for dmconf
optdepends = libnotify: used by dmlogout
optdepends = maim: used by dmscrot
diff --git a/PKGBUILD b/PKGBUILD
index 5808e0844da0..c56b3dacbf1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Derek Taylor (DistroTube) <derek@distrotube.com>
pkgname=dmscripts-git
_pkgname=dmscripts
-pkgver=1.0.r177.cec16c4
+pkgver=1.0.r218.3c86c1f
pkgrel=1
pkgdesc="A collection of dmenu scripts"
arch=('any')
url="https://gitlab.com/dwt1/dmscripts.git"
license=('GPL3')
-depends=(dmenu ffmpeg findutils xclip xdotool xorg-xrandr )
+depends=(dmenu ffmpeg findutils xclip xdotool xorg-xrandr bind jq)
groups=()
-makedepends=()
+makedepends=(pandoc git)
checkdepends=()
optdepends=(
'emacs: editor for dmconf '
@@ -41,14 +41,14 @@ pkgver() {
}
+build() {
+ cd "${_pkgname}"
+ DESTDIR="$pkgdir/" make clean build
+}
+
+
package() {
cd ${_pkgname}
- # Make sure to install all scripts
- for script in $(echo scripts/*); do
- install -Dm755 ${script} -t "${pkgdir}/usr/bin"
- done
- install -Dm644 man/dmscripts.1 "${pkgdir}/usr/local/man/man1/dmscripts.1"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ NAME="${pkgname}" DESTDIR="${pkgdir}/" make install
}