summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2012-02-12 14:10:25 +0000
committerThomas Weißschuh2012-02-12 14:10:25 +0000
commitad851a4240eb60562b037590ded0c834364cc415 (patch)
tree6baa873a5560f13c18a9afda9c34fb7e02fff449
downloadaur-ad851a4240eb60562b037590ded0c834364cc415.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1167b508ece3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dmtx-utils
+ pkgdesc = Utilities to libdmtx
+ pkgver = 0.7.4
+ pkgrel = 1
+ url = http://www.libdmtx.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = libdmtx
+ source = http://downloads.sourceforge.net/libdmtx/dmtx-utils-0.7.4.tar.bz2
+ sha1sums = e56990bf058c109206124f8d9177715b7675e657
+
+pkgname = dmtx-utils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f30be33aa9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Thomas Weißschuh <thomas_weissschuh || lavabit.com >
+
+pkgname=dmtx-utils
+pkgver=0.7.4
+pkgrel=1
+pkgdesc="Utilities to libdmtx"
+url="http://www.libdmtx.org/"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('libdmtx')
+source=("http://downloads.sourceforge.net/libdmtx/${pkgname}-${pkgver}.tar.bz2")
+sha1sums=('e56990bf058c109206124f8d9177715b7675e657')
+
+build() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}