summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Konarev2022-11-14 10:38:07 +0300
committerAlexander Konarev2022-11-14 10:38:07 +0300
commitfeaf35d4959785b195bc5608cd7828054e55e73d (patch)
treeda37f9521c87e6ce24ba2ed595d8b507e7349de9
downloadaur-feaf35d4959785b195bc5608cd7828054e55e73d.tar.gz
create package
-rw-r--r--.SRCINFO22
-rw-r--r--DMusic.desktop16
-rw-r--r--PKGBUILD35
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..999cb135be6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = dmusic
+ pkgdesc = Compact and native Yandex Music client
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/levovix0/DMusic
+ arch = x86_64
+ license = GPL3
+ makedepends = nim
+ depends = taglib
+ depends = qt6-base
+ depends = qt6-declarative
+ depends = qt6-quick3d
+ depends = qt6-quicktimeline
+ depends = qt6-svg
+ depends = qt6-webchannel
+ depends = qt6-webengine
+ source = https://github.com/levovix0/DMusic/archive/refs/tags/0.3.zip
+ source = DMusic.desktop
+ sha256sums = 1f82e732584257246162201bc59b339adca71a90dcd811b775a6b681f067d7f2
+ sha256sums = 5aa2b3210f93963c825373195aae8adaa75edf9c82c59d657c0c3250a37c3a8a
+
+pkgname = dmusic
diff --git a/DMusic.desktop b/DMusic.desktop
new file mode 100644
index 000000000000..1c93c39131c3
--- /dev/null
+++ b/DMusic.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Type=Application
+Name=DMusic Яндекс Музыка
+GenericName=Music player
+GenericName[ru]=Музыкальный проигрыватель Яндекс Музыка
+Comment= Yandex.Music client / music player
+Comment[ru]=Яндекс Музыка клиент
+Icon=/usr/share/DMusic/app.svg
+Exec=/usr/bin/dmusic
+Categories=AudioVideo;
+Terminal=false
+X-AppImage-Version=0.0.0
+Keywords[ru]=музыка;яндекс; плеер
+Keywords=music;yandex;player
+
+SingleMainWindow=true
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30f1a3d7fbf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Alexander Konarev (avkonarev) <AVKonarev@gmail.com>
+
+pkgname=dmusic
+pkgver=0.3
+pkgrel=1
+pkgdesc="Compact and native Yandex Music client"
+arch=('i686' 'x86_64')
+url="https://github.com/levovix0/DMusic"
+license=('GPL3')
+arch=('x86_64')
+source=("https://github.com/levovix0/DMusic/archive/refs/tags/$pkgver.zip"
+ "DMusic.desktop")
+sha256sums=('1f82e732584257246162201bc59b339adca71a90dcd811b775a6b681f067d7f2'
+ '5aa2b3210f93963c825373195aae8adaa75edf9c82c59d657c0c3250a37c3a8a')
+depends=('taglib' 'qt6-base' 'qt6-declarative' 'qt6-quick3d' 'qt6-quicktimeline'
+ 'qt6-svg' 'qt6-webchannel' 'qt6-webengine')
+makedepends=('nim')
+#options=('!strip')
+
+build(){
+ cd $srcdir/DMusic-$pkgver
+ nimble build -d:release
+}
+
+package() {
+ cd $srcdir/DMusic-$pkgver
+ install -dm755 $pkgdir/usr/bin
+ install -Dm755 dmusic $pkgdir/usr/bin/
+
+ install -dm755 $pkgdir/usr/share/DMusic
+ install -Dm755 {resources/app.svg,LICENSE} $pkgdir/usr/share/DMusic
+
+ install -dm755 $pkgdir/usr/share/applications
+ install -Dm755 ../DMusic.desktop $pkgdir/usr/share/applications
+}