summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2018-08-13 20:12:25 +0200
committerlarchunix2018-08-13 20:12:25 +0200
commit008d797fd4e4bcb08dfbbd5724a4cb259ef1aaea (patch)
tree7f84c1771f4b4cc4fb41cec527c0304c87959e91
parent162f2476853e050e3d794ce1743a509b8ec737ce (diff)
downloadaur-008d797fd4e4bcb08dfbbd5724a4cb259ef1aaea.tar.gz
Update to upstream release 3.3.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
-rw-r--r--dnf-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch47
3 files changed, 8 insertions, 63 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a76b923db128..2889decaf3db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dnf
pkgdesc = Package manager forked from Yum, using libsolv as a dependency resolver
- pkgver = 3.2.0
+ pkgver = 3.3.0
pkgrel = 1
url = https://github.com/rpm-software-management/dnf
arch = any
@@ -10,7 +10,7 @@ pkgbase = dnf
makedepends = bash-completion
makedepends = cmake
makedepends = python-sphinx
- depends = libdnf>=0.17.0
+ depends = libdnf>=0.17.2
depends = libcomps>=0.1.8
depends = libmodulemd>=1.4.0
depends = librepo>=1.9.0
@@ -18,14 +18,11 @@ pkgbase = dnf
depends = python-gobject
depends = python-gpgme
depends = python-iniparse
- depends = python-smartcols
depends = rpm-org
backup = etc/dnf/automatic.conf
backup = etc/dnf/dnf.conf
- source = https://github.com/rpm-software-management/dnf/archive/3.2.0/dnf-3.2.0.tar.gz
- source = dnf-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch
- md5sums = ffa210d1ba3508a737ad0efcda356de1
- md5sums = 51bbd2fd1ab2c11057c833adecb8b5fa
+ source = https://github.com/rpm-software-management/dnf/archive/3.3.0/dnf-3.3.0.tar.gz
+ md5sums = b4b8d0e9ce67612b49e2063bb9faadb6
pkgname = dnf
diff --git a/PKGBUILD b/PKGBUILD
index 2e3a5d2cf91c..30af5b8ae3fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,25 @@
pkgname=dnf
-pkgver=3.2.0
+pkgver=3.3.0
pkgrel=1
pkgdesc="Package manager forked from Yum, using libsolv as a dependency resolver"
arch=('any')
url="https://github.com/rpm-software-management/$pkgname"
license=('GPL2' 'GPL')
-depends=('libdnf>=0.17.0' 'libcomps>=0.1.8' 'libmodulemd>=1.4.0'
+depends=('libdnf>=0.17.2' 'libcomps>=0.1.8' 'libmodulemd>=1.4.0'
'librepo>=1.9.0'
'python' 'python-gobject' 'python-gpgme' 'python-iniparse'
- 'python-smartcols'
'rpm-org')
makedepends=('bash-completion' 'cmake' 'python-sphinx')
checkdepends=('python-nose')
backup=("etc/$pkgname/automatic.conf"
"etc/$pkgname/$pkgname.conf")
-source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz"
- "$pkgname-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch")
-md5sums=('ffa210d1ba3508a737ad0efcda356de1'
- '51bbd2fd1ab2c11057c833adecb8b5fa')
+source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('b4b8d0e9ce67612b49e2063bb9faadb6')
prepare() {
cd "$pkgname-$pkgver"
rm -rf build
mkdir build
-
- patch -p1 < "$srcdir/$pkgname-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch"
}
build() {
diff --git a/dnf-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch b/dnf-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch
deleted file mode 100644
index a070c4e000d6..000000000000
--- a/dnf-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 0b2b5c29c1ec89269aef0862981ebf97e2730de9 Mon Sep 17 00:00:00 2001
-From: Denis Ollier <larchunix@users.noreply.github.com>
-Date: Thu, 26 Jul 2018 20:31:36 +0200
-Subject: [PATCH] Fallback to os.getuid() if /proc/self/loginuid can't be read
- (RhBug:1597005)
-
-File /proc/self/loginuid may be missing on architectures (RISC-V) or
-distributions (ArchLinux) where audit subsystem is not enabled.
----
- dnf/yum/misc.py | 11 ++++++-----
- 1 file changed, 6 insertions(+), 5 deletions(-)
-
-diff --git a/dnf/yum/misc.py b/dnf/yum/misc.py
-index 93000ca4..457e8bf5 100644
---- a/dnf/yum/misc.py
-+++ b/dnf/yum/misc.py
-@@ -395,8 +395,8 @@ def stat_f(filename, ignore_EACCES=False):
- raise
-
- def _getloginuid():
-- """ Get the audit-uid/login-uid, if available. None is returned if there
-- was a problem. Note that no caching is done here. """
-+ """ Get the audit-uid/login-uid, if available. os.getuid() is returned
-+ instead if there was a problem. Note that no caching is done here. """
- # We might normally call audit.audit_getloginuid(), except that requires
- # importing all of the audit module. And it doesn't work anyway: BZ 518721
- try:
-@@ -404,12 +404,13 @@ def _getloginuid():
- data = fo.read()
- return int(data)
- except (IOError, ValueError):
-- return None
-+ return os.getuid()
-
- _cached_getloginuid = None
- def getloginuid():
-- """ Get the audit-uid/login-uid, if available. None is returned if there
-- was a problem. The value is cached, so you don't have to save it. """
-+ """ Get the audit-uid/login-uid, if available. os.getuid() is returned
-+ instead if there was a problem. The value is cached, so you don't
-+ have to save it. """
- global _cached_getloginuid
- if _cached_getloginuid is None:
- _cached_getloginuid = _getloginuid()
---
-2.18.0
-