summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2018-06-26 17:58:33 +0200
committerlarchunix2018-06-26 17:58:33 +0200
commitf4600afa4df265c6d6a541b406b9cef58bfd6dae (patch)
treed54cc9cffc7b5019061f22c4c2da2e94f8304af1
parent80ccd1e203aa6ea0d18a05e45b5f59733c21e3c2 (diff)
downloadaur-f4600afa4df265c6d6a541b406b9cef58bfd6dae.tar.gz
Update to upstream release 3.0.1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD20
-rw-r--r--dnf-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch47
3 files changed, 74 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b6ab946d299..2607897c3c7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dnf
pkgdesc = Package manager forked from Yum, using libsolv as a dependency resolver
- pkgver = 2.7.5
+ pkgver = 3.0.1
pkgrel = 1
url = https://github.com/rpm-software-management/dnf
arch = any
@@ -10,17 +10,22 @@ pkgbase = dnf
makedepends = bash-completion
makedepends = cmake
makedepends = python-sphinx
- depends = libdnf>=0.10.1
- depends = libcomps
- depends = librepo
- depends = rpm-org
+ depends = libdnf>=0.14.0
+ depends = libcomps>=0.1.8
+ depends = libmodulemd>=1.4.0
+ depends = librepo>=1.9.0
depends = python
- depends = python-iniparse
+ depends = python-gobject
depends = python-gpgme
+ depends = python-iniparse
+ depends = python-smartcols
+ depends = rpm-org
backup = etc/dnf/automatic.conf
backup = etc/dnf/dnf.conf
- source = https://github.com/rpm-software-management/dnf/archive/2.7.5/dnf-2.7.5.tar.gz
- md5sums = a57be9b448b4093c0943170c4a021155
+ source = https://github.com/rpm-software-management/dnf/archive/3.0.1/dnf-3.0.1.tar.gz
+ source = dnf-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch
+ md5sums = f48fa08bfe26cf34ba0561f623fdee1c
+ md5sums = 51bbd2fd1ab2c11057c833adecb8b5fa
pkgname = dnf
diff --git a/PKGBUILD b/PKGBUILD
index f87491012415..97eea22f7574 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,30 @@
pkgname=dnf
-pkgver=2.7.5
+pkgver=3.0.1
pkgrel=1
pkgdesc="Package manager forked from Yum, using libsolv as a dependency resolver"
arch=('any')
url="https://github.com/rpm-software-management/$pkgname"
license=('GPL2' 'GPL')
-depends=('libdnf>=0.10.1' 'libcomps' 'librepo' 'rpm-org'
- 'python' 'python-iniparse' 'python-gpgme')
+depends=('libdnf>=0.14.0' 'libcomps>=0.1.8' 'libmodulemd>=1.4.0'
+ 'librepo>=1.9.0'
+ 'python' 'python-gobject' 'python-gpgme' 'python-iniparse'
+ 'python-smartcols'
+ 'rpm-org')
makedepends=('bash-completion' 'cmake' 'python-sphinx')
checkdepends=('python-nose')
backup=("etc/$pkgname/automatic.conf"
"etc/$pkgname/$pkgname.conf")
-source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('a57be9b448b4093c0943170c4a021155')
+source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz"
+ "$pkgname-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch")
+md5sums=('f48fa08bfe26cf34ba0561f623fdee1c'
+ '51bbd2fd1ab2c11057c833adecb8b5fa')
prepare() {
cd "$pkgname-$pkgver"
rm -rf build
mkdir build
+
+ patch -p1 < "$srcdir/$pkgname-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch"
}
build() {
@@ -40,7 +47,8 @@ package() {
cd "$pkgname-$pkgver"/build
make DESTDIR="$pkgdir/" install
- rm "$pkgdir/usr/share/man/man8/yum.8"
+ rm "$pkgdir/usr/share/man/man8/yum.8" \
+ "$pkgdir/usr/share/man/man5/yum.conf.5"
ln -s $pkgname-3 "$pkgdir/usr/bin/$pkgname"
ln -s $pkgname-automatic-3 "$pkgdir/usr/bin/$pkgname-automatic"
diff --git a/dnf-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch b/dnf-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch
new file mode 100644
index 000000000000..a070c4e000d6
--- /dev/null
+++ b/dnf-3.0.1-fallback-to-getuid-if-audit-is-disabled.patch
@@ -0,0 +1,47 @@
+From 0b2b5c29c1ec89269aef0862981ebf97e2730de9 Mon Sep 17 00:00:00 2001
+From: Denis Ollier <larchunix@users.noreply.github.com>
+Date: Thu, 26 Jul 2018 20:31:36 +0200
+Subject: [PATCH] Fallback to os.getuid() if /proc/self/loginuid can't be read
+ (RhBug:1597005)
+
+File /proc/self/loginuid may be missing on architectures (RISC-V) or
+distributions (ArchLinux) where audit subsystem is not enabled.
+---
+ dnf/yum/misc.py | 11 ++++++-----
+ 1 file changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/dnf/yum/misc.py b/dnf/yum/misc.py
+index 93000ca4..457e8bf5 100644
+--- a/dnf/yum/misc.py
++++ b/dnf/yum/misc.py
+@@ -395,8 +395,8 @@ def stat_f(filename, ignore_EACCES=False):
+ raise
+
+ def _getloginuid():
+- """ Get the audit-uid/login-uid, if available. None is returned if there
+- was a problem. Note that no caching is done here. """
++ """ Get the audit-uid/login-uid, if available. os.getuid() is returned
++ instead if there was a problem. Note that no caching is done here. """
+ # We might normally call audit.audit_getloginuid(), except that requires
+ # importing all of the audit module. And it doesn't work anyway: BZ 518721
+ try:
+@@ -404,12 +404,13 @@ def _getloginuid():
+ data = fo.read()
+ return int(data)
+ except (IOError, ValueError):
+- return None
++ return os.getuid()
+
+ _cached_getloginuid = None
+ def getloginuid():
+- """ Get the audit-uid/login-uid, if available. None is returned if there
+- was a problem. The value is cached, so you don't have to save it. """
++ """ Get the audit-uid/login-uid, if available. os.getuid() is returned
++ instead if there was a problem. The value is cached, so you don't
++ have to save it. """
+ global _cached_getloginuid
+ if _cached_getloginuid is None:
+ _cached_getloginuid = _getloginuid()
+--
+2.18.0
+