summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2023-05-18 13:27:30 +0200
committerlarchunix2023-05-18 13:27:30 +0200
commit9503a5a77d10679898898a9ccc927db76fe7212e (patch)
tree76a0eed244dfe84440346aa4cec90f6145b79742
parent040fc7f3cdab66a44cc322856c5023699deb97da (diff)
downloadaur-9503a5a77d10679898898a9ccc927db76fe7212e.tar.gz
Update to upstream release 4.4.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e9bf92bf62a..651f48d2e0d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dnf-plugins-core
pkgdesc = Core DNF Plugins
- pkgver = 4.4.0
+ pkgver = 4.4.1
pkgrel = 1
url = https://github.com/rpm-software-management/dnf-plugins-core
arch = any
@@ -24,7 +24,7 @@ pkgbase = dnf-plugins-core
backup = etc/dnf/plugins/post-transaction-actions.conf
backup = etc/dnf/plugins/versionlock.conf
backup = etc/dnf/plugins/versionlock.list
- source = https://github.com/rpm-software-management/dnf-plugins-core/archive/4.4.0/dnf-plugins-core-4.4.0.tar.gz
- sha256sums = e2fbaa81e5f512c3ec8a4a3e4a7e5a92bf0d7e122becc7ed2b6b756fec76a017
+ source = https://github.com/rpm-software-management/dnf-plugins-core/archive/4.4.1/dnf-plugins-core-4.4.1.tar.gz
+ sha256sums = ae00921b98b2e5cb6454d47907f1516612f991ad6a4a0a2adbb01446208a70f9
pkgname = dnf-plugins-core
diff --git a/PKGBUILD b/PKGBUILD
index 0bffd3ec4309..cd4849d6adb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=dnf-plugins-core
-pkgver=4.4.0
+pkgver=4.4.1
pkgrel=1
pkgdesc="Core DNF Plugins"
arch=('any')
@@ -22,7 +22,7 @@ backup=('etc/dnf/plugins/copr.conf'
'etc/dnf/plugins/versionlock.list')
options=('!emptydirs')
source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('e2fbaa81e5f512c3ec8a4a3e4a7e5a92bf0d7e122becc7ed2b6b756fec76a017')
+sha256sums=('ae00921b98b2e5cb6454d47907f1516612f991ad6a4a0a2adbb01446208a70f9')
prepare() {
cd "$pkgname-$pkgver"
@@ -40,21 +40,21 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DPYTHON_DESIRED=3
- make -C build
- make -C build doc-man
+ cmake --build build
+ cmake --build build --target doc-man
}
check() {
cd "$pkgname-$pkgver"
# Tests fail with non-english locales
- LC_ALL=en_US.UTF-8 ctest -VV --test-dir build
+ LC_ALL=en_US.UTF-8 ctest --test-dir build --output-on-failure
}
package() {
cd "$pkgname-$pkgver"
- make -C build DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
install -Dp -m644 README.rst "$pkgdir/usr/share/doc/$pkgname/README.rst"