summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2020-10-07 22:11:28 +0200
committerlarchunix2020-10-07 22:11:28 +0200
commit4d6f2f1d576235bd033930ca8026a00e681db840 (patch)
tree18f2c6d48b13fc69f497a27eafc081c44ddbd40b
parentd190764f3c59224a97a46b1de1f99c677922857d (diff)
downloadaur-4d6f2f1d576235bd033930ca8026a00e681db840.tar.gz
Update to upstream release 4.0.11
Also try to comply with Arch Linux CMake package guidelines: => https://wiki.archlinux.org/index.php/CMake_package_guidelines
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e926c49b099..840bf6c61aa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = dnf-plugins-extras
pkgdesc = Extras DNF Plugins
- pkgver = 4.0.10
+ pkgver = 4.0.11
pkgrel = 1
url = https://github.com/rpm-software-management/dnf-plugins-extras
arch = any
license = GPL2
checkdepends = python-nose
- makedepends = cmake
+ makedepends = cmake>=3.13
makedepends = python-sphinx
depends = dnf>=4.2.19
depends = python
@@ -14,8 +14,8 @@ pkgbase = dnf-plugins-extras
optdepends = tracer: for tracer plugin
backup = etc/dnf/plugins/rpmconf.conf
backup = etc/dnf/plugins/torproxy.conf
- source = https://github.com/rpm-software-management/dnf-plugins-extras/archive/4.0.10/dnf-plugins-extras-4.0.10.tar.gz
- md5sums = 52e5d0696678124c7bf334d9ef05251e
+ source = https://github.com/rpm-software-management/dnf-plugins-extras/archive/4.0.11/dnf-plugins-extras-4.0.11.tar.gz
+ md5sums = 4dd943e4573bced8fe47237369997fc3
pkgname = dnf-plugins-extras
diff --git a/PKGBUILD b/PKGBUILD
index 557c8f3d8c85..757d5485fb9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,22 @@
pkgname=dnf-plugins-extras
-pkgver=4.0.10
+pkgver=4.0.11
pkgrel=1
pkgdesc="Extras DNF Plugins"
arch=('any')
url="https://github.com/rpm-software-management/$pkgname"
license=('GPL2')
depends=('dnf>=4.2.19' 'python')
-makedepends=('cmake' 'python-sphinx')
+makedepends=('cmake>=3.13' 'python-sphinx')
checkdepends=('python-nose')
optdepends=('snapper: for snapper plugin'
'tracer: for tracer plugin')
backup=('etc/dnf/plugins/rpmconf.conf'
'etc/dnf/plugins/torproxy.conf')
source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('52e5d0696678124c7bf334d9ef05251e')
+md5sums=('4dd943e4573bced8fe47237369997fc3')
prepare() {
cd "$pkgname-$pkgver"
- rm -rf build
- mkdir build
# sphinx-build-3 does not exist on Arch Linux,
# use sphinx-build instead
@@ -27,26 +25,29 @@ prepare() {
}
build() {
- cd "$pkgname-$pkgver"/build
- cmake -DCMAKE_BUILD_TYPE=Release \
+ cd "$pkgname-$pkgver"
+
+ cmake -B build \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DPYTHON_DESIRED=3 \
- ..
- make
- make doc-man
+ -DPYTHON_DESIRED=3
+
+ make -C build
+ make -C build doc-man
}
# Tests seem to need a minimal RPM database on the system
#check() {
# cd "$pkgname-$pkgver"
+#
# PYTHONPATH=./plugins nosetests -s tests
#}
package() {
- cd "$pkgname-$pkgver"/build
- make DESTDIR="$pkgdir/" install
+ cd "$pkgname-$pkgver"
+
+ make -C build DESTDIR="$pkgdir/" install
- install -Dp -m644 ../README.rst "$pkgdir/usr/share/doc/$pkgname/README.rst"
+ install -Dp -m644 README.rst "$pkgdir/usr/share/doc/$pkgname/README.rst"
}
# vim: set ft=sh ts=4 sw=4 noet: