summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2016-11-25 22:11:53 +0100
committerlarchunix2016-11-25 22:11:53 +0100
commit61c19394333e58063f75fac0381320cc27fbdd4f (patch)
tree3212fbbf520251c64e2f287ac1d9f42fbc6c4f16
parentb5b2d93ba4a6c9250266571d02593490232fa04c (diff)
downloadaur-61c19394333e58063f75fac0381320cc27fbdd4f.tar.gz
Update to upstream release 0.10.0-rc1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 22 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1dd4dcb2614..15ea4c8961eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Dec 12 22:41:49 UTC 2015
pkgbase = dnf-plugins-extras
pkgdesc = Extras DNF Plugins
- pkgver = 0.0.12
+ pkgver = 0.10.0.rc1
pkgrel = 1
url = https://github.com/rpm-software-management/dnf-plugins-extras
arch = any
@@ -10,14 +8,19 @@ pkgbase = dnf-plugins-extras
checkdepends = python-nose
makedepends = cmake
makedepends = python-sphinx
- depends = dnf
+ depends = dnf>=2.0.0
depends = python
optdepends = createrepo_c: for local plugin
optdepends = snapper: for snapper plugin
optdepends = tracer: for tracer plugin
options = !emptydirs
- source = dnf-plugins-extras-0.0.12.tar.gz::https://github.com/rpm-software-management/dnf-plugins-extras/archive/0.0.12.tar.gz
- md5sums = 48dfbf03df53dc0d29dc6e0acdf1f5da
+ backup = etc/dnf/plugins/local.conf
+ backup = etc/dnf/plugins/rpmconf.conf
+ backup = etc/dnf/plugins/torproxy.conf
+ backup = etc/dnf/plugins/versionlock.conf
+ backup = etc/dnf/plugins/versionlock.list
+ source = https://github.com/rpm-software-management/dnf-plugins-extras/archive/0.10.0-rc1/dnf-plugins-extras-0.10.0-rc1.tar.gz
+ md5sums = 3eab757ba60b7fcf6ad4ecc42fc38fcc
pkgname = dnf-plugins-extras
diff --git a/PKGBUILD b/PKGBUILD
index 1dd0e837c06b..af17dec15aae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,29 @@
pkgname=dnf-plugins-extras
-pkgver=0.0.12
+_pkgver=0.10.0-rc1
+pkgver=0.10.0.rc1
pkgrel=1
pkgdesc="Extras DNF Plugins"
arch=('any')
url="https://github.com/rpm-software-management/$pkgname"
license=('GPL2')
-depends=('dnf' 'python')
+depends=('dnf>=2.0.0' 'python')
makedepends=('cmake' 'python-sphinx')
checkdepends=('python-nose')
optdepends=('createrepo_c: for local plugin'
'snapper: for snapper plugin'
'tracer: for tracer plugin')
+backup=('etc/dnf/plugins/local.conf'
+ 'etc/dnf/plugins/rpmconf.conf'
+ 'etc/dnf/plugins/torproxy.conf'
+ 'etc/dnf/plugins/versionlock.conf'
+ 'etc/dnf/plugins/versionlock.list')
options=(!emptydirs)
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-md5sums=('48dfbf03df53dc0d29dc6e0acdf1f5da')
+source=("$url/archive/$_pkgver/$pkgname-$_pkgver.tar.gz")
+md5sums=('3eab757ba60b7fcf6ad4ecc42fc38fcc')
prepare() {
+ mv "$pkgname-$_pkgver" "$pkgname-$pkgver"
+
cd "$pkgname-$pkgver"
rm -rf build
mkdir build
@@ -28,8 +36,7 @@ build() {
-DPYTHON_DESIRED=3 \
..
make
- # sphinx-build fails with non UTF-8 locales
- make LC_ALL=en_US.UTF-8 doc-man
+ make doc-man
}
# Tests seem to need a minimal RPM database on the system