summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2018-08-10 13:37:23 +0200
committerAlexander F. Rødseth2018-08-10 13:37:23 +0200
commit16eeb3733ff652887b093943980ed9bb86ac1928 (patch)
tree6854f63067bf531b4da1d0e00da135a191a1065f
downloadaur-16eeb3733ff652887b093943980ed9bb86ac1928.tar.gz
Add dnload
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec8ed355c304
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Aug 10 11:37:10 UTC 2018
+pkgbase = dnload
+ pkgdesc = Build small executables
+ pkgver = r14
+ pkgrel = 1
+ url = https://github.com/faemiyah/dnload/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ source = dnload::git+https://github.com/xyproto/shrinky#branch=arch
+ md5sums = SKIP
+
+pkgname = dnload
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e409c1e599f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=dnload
+pkgver=r14
+pkgrel=1
+pkgdesc='Build small executables'
+arch=('any')
+url='https://github.com/faemiyah/dnload/'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools' 'git')
+
+# Using alternative repository that works for Arch Linux, while waiting for pull request
+#source=("git+https://github.com/faemiyah/dnload#tag=v$pkgver")
+source=("dnload::git+https://github.com/xyproto/shrinky#branch=arch")
+
+md5sums=('SKIP')
+
+package() {
+ cd "$pkgname"
+ python setup.py install --optimize=1 --root "$pkgdir"
+ install -Dm755 dnload.sh "$pkgdir/usr/bin/$pkgname"
+
+ #install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LI*E "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: