summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhashworks2020-06-17 17:21:29 +0200
committerhashworks2020-06-17 17:21:29 +0200
commitfd4ce1c6aea7065b480e8bb61038274ac2febc76 (patch)
treecb24c8b2d4343a0870ba41eff64a83f581f21cac
parentd5b9be5c1cc554ccdde3c0b118fc6335bc3525b2 (diff)
downloadaur-fd4ce1c6aea7065b480e8bb61038274ac2febc76.tar.gz
Add MIT license file
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD34
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03df2e059eb8..423891c56eaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dns-zone-blacklist-git
pkgdesc = dnsmasq, bind and unbound zone files to be used in DNS based AD Blockers
- pkgver = r409.676938e
+ pkgver = r412.73ebd31
pkgrel = 1
url = https://github.com/oznu/dns-zone-blacklist
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index f42e9cfc0bfd..eff633b27fa3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,29 @@
# Maintainer: hashworks <mail@hashworks.net>
pkgname=dns-zone-blacklist-git
-pkgver=r409.676938e
+_pkgname="${pkgname%-git}"
+pkgver=r412.73ebd31
pkgrel=1
-pkgdesc='dnsmasq, bind and unbound zone files to be used in DNS based AD Blockers'
-url='https://github.com/oznu/dns-zone-blacklist'
-arch=('any')
-license=('MIT') # https://github.com/oznu/dns-zone-blacklist/blob/master/package.json#L10
-conflicts=('dns-zone-blacklist')
-provides=('dns-zone-blacklist')
-optdepends=('unbound' 'bind' 'dnsmasq')
-makedepends=('git')
-source=('git+https://github.com/oznu/dns-zone-blacklist.git')
-sha256sums=('SKIP')
+pkgdesc="dnsmasq, bind and unbound zone files to be used in DNS based AD Blockers"
+url="https://github.com/oznu/dns-zone-blacklist"
+arch=("any")
+license=("MIT")
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+optdepends=("unbound" "bind" "dnsmasq")
+makedepends=("git")
+source=("git+https://github.com/oznu/dns-zone-blacklist.git")
+sha256sums=("SKIP")
pkgver() {
- cd "dns-zone-blacklist"
+ cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- mkdir -p "${pkgdir}/etc/dns-zone-blacklist"
- cd "dns-zone-blacklist"
- rm */*.checksum
- cp -r bind dnsmasq unbound "${pkgdir}/etc/dns-zone-blacklist"
+ cd "${_pkgname}"
+ find . -type f -name "*.checksum" -delete
+ mkdir -p "${pkgdir}/etc/${_pkgname}"
+ cp -r bind dnsmasq unbound "${pkgdir}/etc/${_pkgname}"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}