summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Natalenko2016-07-04 14:20:17 +0300
committerOleksandr Natalenko2016-07-04 14:20:17 +0300
commitdf4a12bfc54eb93a55300c3d412bea2271e0a220 (patch)
treecf69c9471754dac079946708166ff4159a780e66
parent29428d6f8bf2d4bf41172a2b9842ae436c29ac30 (diff)
downloadaur-df4a12bfc54eb93a55300c3d412bea2271e0a220.tar.gz
update to v0.0.1-3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
-rw-r--r--dnsbalancer.service15
3 files changed, 13 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d788bf6b96a..5be945384255 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Dec 11 23:01:33 UTC 2015
+# Mon Jul 4 11:19:58 UTC 2016
pkgbase = dnsbalancer
pkgdesc = Daemon to balance UDP DNS requests over DNS servers
pkgver = 0.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/LanetNetwork/dnsbalancer
arch = x86_64
license = GPL
@@ -11,15 +11,14 @@ pkgbase = dnsbalancer
makedepends = gcc
makedepends = cmake
makedepends = make
- depends = iniparser
depends = libmicrohttpd
depends = libbsd
depends = ldns
+ depends = openssl
+ depends = libunwind
optdepends = gperftools: faster memory allocation with tcmalloc
source = dnsbalancer-git::git+https://github.com/LanetNetwork/dnsbalancer.git
- source = dnsbalancer.service
sha256sums = SKIP
- sha256sums = 0ba09709bdadcdbab31e29dabd11b126bac549b31773c4f44693226622a9f723
pkgname = dnsbalancer
diff --git a/PKGBUILD b/PKGBUILD
index 1d204336a1e4..7a645c3713e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,35 @@
# Maintainer: Oleksandr Natalenko <oleksandr@natalenko.name>
pkgname=dnsbalancer
pkgver=0.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="Daemon to balance UDP DNS requests over DNS servers"
arch=('x86_64')
url="https://github.com/LanetNetwork/${pkgname}"
license=('GPL')
-depends=('iniparser' 'libmicrohttpd' 'libbsd' 'ldns')
+depends=('libmicrohttpd' 'libbsd' 'ldns' 'openssl' 'libunwind')
optdepends=('gperftools: faster memory allocation with tcmalloc')
makedepends=('git' 'gcc' 'cmake' 'make')
-source=(
- "${pkgname}-git::git+https://github.com/LanetNetwork/${pkgname}.git"
- "dnsbalancer.service"
- )
+source=("${pkgname}-git::git+https://github.com/LanetNetwork/${pkgname}.git")
-sha256sums=(
- "SKIP"
- "0ba09709bdadcdbab31e29dabd11b126bac549b31773c4f44693226622a9f723"
- )
+sha256sums=("SKIP")
build() {
cd "${srcdir}/${pkgname}-git"
- git submodule update --init --recursive
-
mkdir -p build
cd build
- cmake -DCMAKE_BUILD_TYPE=Release -DDB_INIPARSER4=1 -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
make -j$(nproc)
}
package() {
cd "${srcdir}/${pkgname}-git/build"
+
make install
- install -Dm0644 ../${pkgname}.conf.sample ${pkgdir}/etc/${pkgname}/${pkgname}.conf.sample
- install -Dm0644 ../../${pkgname}.service ${pkgdir}/usr/lib/systemd/system/${pkgname}.service
+
+ install -Dm0644 ../configs/${pkgname}.conf.sample ${pkgdir}/etc/${pkgname}/${pkgname}.conf.sample
+ install -Dm0644 ../configs/${pkgname}.service ${pkgdir}/usr/lib/systemd/system/${pkgname}.service
}
diff --git a/dnsbalancer.service b/dnsbalancer.service
deleted file mode 100644
index 1f1c1be14f42..000000000000
--- a/dnsbalancer.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=UDP DNS balancer
-After=network.target
-
-[Service]
-Type=forking
-PrivateTmp=true
-PIDFile=/run/dnsbalancer.pid
-Nice=-1
-ExecStart=/usr/bin/dnsbalancer --config=/etc/dnsbalancer/dnsbalancer.conf --pid-file=/run/dnsbalancer.pid --daemonize --syslog
-Restart=always
-
-[Install]
-WantedBy=multi-user.target
-