summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Grunbaum2020-10-23 16:04:29 +1100
committerJoel Grunbaum2020-10-23 16:04:29 +1100
commit21b2e240cce84667d1983c9d1dee77f43c0e3d8f (patch)
treeadf9f3a1733a9e26a2689e24e5b68c18b53943dc
downloadaur-21b2e240cce84667d1983c9d1dee77f43c0e3d8f.tar.gz
initial commit to add to AUR
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e050fbf21b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dnscomp-git
+ pkgdesc = A simple, fast DNS benchmark tool
+ pkgver = 0.r24.6336e52
+ pkgrel = 1
+ url = https://github.com/Chizi123/dnscomp.git
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ provides = dnscomp
+ source = dnscomp::git+https://github.com/Chizi123/dnscomp.git
+ md5sums = SKIP
+
+pkgname = dnscomp-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ef605824ce1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Joel Grunbaum <joel@joelg.net>
+_pkgname=dnscomp
+pkgname=$_pkgname-git
+pkgver=0.r24.6336e52
+pkgrel=1
+pkgdesc="A simple, fast DNS benchmark tool"
+arch=('x86_64')
+license=('GPL3')
+makedepends=('git')
+provides=("$_pkgname")
+source=("$_pkgname::git+https://github.com/Chizi123/dnscomp.git")
+url="https://github.com/Chizi123/dnscomp.git"
+md5sums=('SKIP')
+
+pkgver () {
+ cd "$_pkgname"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build () {
+ cd "$_pkgname"
+ CFLAGS="-O2 -lpthread" make
+}
+
+package () {
+ cd "$_pkgname"
+ install -Dm755 dnscomp "$pkgdir/usr/bin/dnscomp"
+}