summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Shaughnessy2020-06-29 17:08:15 +0100
committerMax Shaughnessy2020-06-29 17:13:45 +0100
commit5d912d000a674652cd4e555297bca664ab2fee27 (patch)
tree56f1883fb164008a055014e17259063e944ea1eb
parent21c95b1f364cc203bc318ef7579f9fa464a0db7f (diff)
downloadaur-5d912d000a674652cd4e555297bca664ab2fee27.tar.gz
Add correct license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 573678eaa853..fd427838f914 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = dnscontrol
pkgrel = 1
url = https://stackexchange.github.io/dnscontrol/
arch = x86_64
- license = GPL
+ license = MIT
makedepends = go-pie
depends = glibc
provides = dnscontrol=2.11
diff --git a/PKGBUILD b/PKGBUILD
index c3a660076b98..1eb5639f987e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
# Maintainer: AdmiringWorm <kim.nordmo@gmail.com>
+# Maintainer: Max Shaughnessy <msh@lap.is>
+
pkgname=dnscontrol
pkgver=2.11
pkgrel=1
-pkgdesc="Synchronize your DNS to multiple providers from a simple DSL "
+pkgdesc="Synchronize your DNS to multiple providers from a simple DSL"
arch=('x86_64')
url="https://stackexchange.github.io/${pkgname}/"
-license=('GPL')
+license=('MIT')
depends=('glibc')
makedepends=('go-pie')
provides=("${pkgname}=${pkgver}")
@@ -18,7 +20,7 @@ prepare(){
}
build() {
- export GOPATH="$srcdir"/gopath
+ export GOPATH="${srcdir}/gopath"
cd gopath/src/github.com/StackExchange/dnscontrol
go build \
@@ -29,5 +31,6 @@ build() {
}
package() {
- install -Dm755 gopath/src/github.com/StackExchange/dnscontrol/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm755 gopath/src/github.com/StackExchange/dnscontrol/$pkgname "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 gopath/src/github.com/StackExchange/dnscontrol/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}