summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Gacogne2018-06-08 08:56:04 +0200
committerRemi Gacogne2018-06-08 08:56:04 +0200
commitd1e88597c9317d2267b29f52e6cf1e44c56dba93 (patch)
tree653e4bc86f499856fce382d70aeb532b6d0c60a8
parent0d8cda8c524571f610f7eb192e8bb66ec95d7a72 (diff)
downloadaur-d1e88597c9317d2267b29f52e6cf1e44c56dba93.tar.gz
dnsdist: Fix building against boost 1.67
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--theL-boost-1.67.patch11
3 files changed, 23 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 505450a96e6d..31f9ea7c5df9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Mar 30 08:45:46 UTC 2018
+# Fri Jun 8 06:55:11 UTC 2018
pkgbase = dnsdist
pkgdesc = Highly DNS-, DoS- and abuse-aware loadbalancer
pkgver = 1.3.0
@@ -22,9 +22,11 @@ pkgbase = dnsdist
source = https://downloads.powerdns.com/releases/dnsdist-1.3.0.tar.bz2
source = https://downloads.powerdns.com/releases/dnsdist-1.3.0.tar.bz2.asc
source = sysusers.conf
+ source = theL-boost-1.67.patch
sha512sums = 35c5dd1f5104ed7f043ce04cbaac14e2eebb2b61ed827e838f5ac0ee1fd4afd4310853df8a193abc37654d2438b10297c611d4b05d8d1bd5e50424d1409851dc
sha512sums = SKIP
sha512sums = d55ccd612cbe08b353815027d30a3b0f0ec7bf6b0d74a0a634939be53ce6e6b41d23e54c2328946f00738c03e9f306ce4f2dabe5e4b11d9fb28d0abf49917893
+ sha512sums = 816c74e9a0516593cd420511525b1f5be8e5dac136bf185b2762686496f221e6a1614349dcf1747a5fc8aa185a157b5fd73ca8bd3198a40369d09114f75daff0
pkgname = dnsdist
diff --git a/PKGBUILD b/PKGBUILD
index e073787aec9b..98891e974986 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,21 @@ arch=('x86_64')
url='https://dnsdist.org/'
license=('GPL2')
source=(https://downloads.powerdns.com/releases/${pkgname}-${pkgver}.tar.bz2{,.asc}
- sysusers.conf)
+ sysusers.conf
+ theL-boost-1.67.patch)
sha512sums=('35c5dd1f5104ed7f043ce04cbaac14e2eebb2b61ed827e838f5ac0ee1fd4afd4310853df8a193abc37654d2438b10297c611d4b05d8d1bd5e50424d1409851dc'
'SKIP'
- 'd55ccd612cbe08b353815027d30a3b0f0ec7bf6b0d74a0a634939be53ce6e6b41d23e54c2328946f00738c03e9f306ce4f2dabe5e4b11d9fb28d0abf49917893')
+ 'd55ccd612cbe08b353815027d30a3b0f0ec7bf6b0d74a0a634939be53ce6e6b41d23e54c2328946f00738c03e9f306ce4f2dabe5e4b11d9fb28d0abf49917893'
+ '816c74e9a0516593cd420511525b1f5be8e5dac136bf185b2762686496f221e6a1614349dcf1747a5fc8aa185a157b5fd73ca8bd3198a40369d09114f75daff0')
validpgpkeys=('D6300CABCBF469BBE392E503A208ED4F8AF58446') # Remi Gacogne <remi.gacogne@powerdns.com>
makedepends=('boost' 'systemd')
depends=('fstrm' 'gnutls' 'libedit' 'libsodium' 'libsystemd' 'luajit' 'net-snmp' 'openssl' 'protobuf' 're2')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -Np1 -i ../theL-boost-1.67.patch
+}
+
build() {
cd "${pkgname}-${pkgver}"
./configure \
diff --git a/theL-boost-1.67.patch b/theL-boost-1.67.patch
new file mode 100644
index 000000000000..53f3d8bc17c4
--- /dev/null
+++ b/theL-boost-1.67.patch
@@ -0,0 +1,11 @@
+diff -ru dnsdist-1.3.0.orig/dns.hh dnsdist-1.3.0/dns.hh
+--- dnsdist-1.3.0.orig/dns.hh 2018-03-29 17:25:58.000000000 +0200
++++ dnsdist-1.3.0/dns.hh 2018-06-08 08:47:00.927516208 +0200
+@@ -235,7 +235,6 @@
+ #define FLAGS_CD_OFFSET (12)
+ #endif
+
+-#define L theL()
+ extern time_t s_starttime;
+
+ uint32_t hashQuestion(const char* packet, uint16_t len, uint32_t init);