summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian2019-10-30 15:07:54 +0100
committerSebastian2019-10-30 15:07:54 +0100
commit79a5afe6cbfd088d23a78efbf888b4e2ae815611 (patch)
tree79c73e3937326a8dc9be4ba706518eb227513ba1
downloadaur-79a5afe6cbfd088d23a78efbf888b4e2ae815611.tar.gz
initial submission
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50e10fc35278
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dnslookup-git
+ pkgdesc = Simple command line utility to make DNS lookups to the specified server
+ pkgver = 10.ae36d05
+ pkgrel = 1
+ url = https://github.com/ameshkov/dnslookup
+ arch = any
+ license = GPL3
+ makedepends = go
+ makedepends = git
+ source = git://github.com/ameshkov/dnslookup.git
+ sha1sums = SKIP
+
+pkgname = dnslookup-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5783eeef6a4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sebastian Meßlinger <sebastian.messlinger@posteo.de>
+pkgname=dnslookup-git
+pkgver=10.ae36d05
+pkgrel=1
+pkgdesc="Simple command line utility to make DNS lookups to the specified server"
+arch=('any')
+url="https://github.com/ameshkov/dnslookup"
+license=('GPL3')
+depends=()
+makedepends=('go' 'git')
+source=('git://github.com/ameshkov/dnslookup.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build(){
+ cd "${srcdir}/dnslookup"
+ mkdir -p "${srcdir}/gopath"
+ export GOPATH="${srcdir}/gopath"
+ go install -x -v -buildmode=pie -ldflags "-s -w" -trimpath
+}
+
+package(){
+ mkdir -p $pkgdir/usr/bin
+ install $srcdir/gopath/bin/dnslookup $pkgdir/usr/bin/dnslookup
+}