summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÓscar García Amor2018-06-27 14:23:16 +0200
committerÓscar García Amor2018-06-27 14:23:16 +0200
commit846329cae53576c5e27fdad96be0024fd8e93248 (patch)
treec95934819d5ce703308b09f47b42709f331487c2
downloadaur-846329cae53576c5e27fdad96be0024fd8e93248.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e9af921f087
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = dnsmorph
+ pkgdesc = Domain name permutation engine written in Go
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/netevert/dnsmorph
+ arch = any
+ license = MIT
+ makedepends = go
+ source = https://github.com/netevert/dnsmorph/archive/v.1.2.2.tar.gz
+ sha256sums = 1b581fe550a95a0ee47f145bed5554f35e9f01f234895eeaa7c789294a1dd743
+
+pkgname = dnsmorph
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..124c5085281b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
+
+pkgname=dnsmorph
+pkgver=1.2.2
+pkgrel=1
+pkgdesc='Domain name permutation engine written in Go'
+arch=('any')
+url='https://github.com/netevert/dnsmorph'
+license=('MIT')
+makedepends=('go')
+source=("https://github.com/netevert/${pkgname}/archive/v.${pkgver}.tar.gz")
+sha256sums=('1b581fe550a95a0ee47f145bed5554f35e9f01f234895eeaa7c789294a1dd743')
+
+build() {
+ export GOPATH="${srcdir}"
+ mkdir -p "${srcdir}/src/github.com/netevert"
+ ln -fsT "${srcdir}/${pkgname}-v.${pkgver}" "${srcdir}/src/github.com/netevert/${pkgname}"
+ cd "${srcdir}/src/github.com/netevert/${pkgname}"
+ go get -v ./...
+}
+
+package() {
+ # binary
+ install -Dm755 bin/dnsmorph "${pkgdir}/usr/bin/dnsmorph"
+}