summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-09-30 15:51:53 +1300
committercaltlgin2020-09-30 15:51:53 +1300
commit9d9873fbce8cfc9d52077831be5b4fda3d2e7cfc (patch)
tree9ed051645eb7c3e2a3bf6e47e26c79a8fe4fbe1d
parent79deb43407ec8372d7511e1345121dd76793831c (diff)
downloadaur-9d9873fbce8cfc9d52077831be5b4fda3d2e7cfc.tar.gz
Add "go clean -modcache"
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a2ab5db8daf..99db366c17bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
-pkgname=dnsprobe
+pkgname='dnsprobe'
pkgver=1.0.3
pkgrel=1
pkgdesc='Perform multiple dns queries of your choice with a list of user supplied resolvers'
@@ -12,13 +12,17 @@ provides=("${pkgname}")
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
sha256sums=('ab57f348177594018cc5b5b5e808710c88e597888c6d504cb10554d60627eae1')
+prepare() {
+ export GOPATH="${srcdir}/gopath"
+ go clean -modcache
+}
+
build() {
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- export GOPATH="${srcdir}"
cd "${pkgname}-${pkgver}"
go build -v -o "${pkgname}" .