summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoredward-p2020-06-23 21:24:16 +0800
committeredward-p2020-06-23 21:42:51 +0800
commit85f1e55a60747004133c6feb9ca41b9271a7a9a6 (patch)
tree5b62fe29db02bca671969812ded95f059fb0cb89
parent13dfadc7f10b630fdd3119094b5ca605df3dc645 (diff)
downloadaur-85f1e55a60747004133c6feb9ca41b9271a7a9a6.tar.gz
dnsproxy-adguard: update -> 0.29.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--dnsproxy-adguard@.service12
3 files changed, 23 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a548124bce1d..7cfcc1b45c80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dnsproxy-adguard
pkgdesc = Simple DNS proxy with DoH, DoT, and DNSCrypt support by AdguardTeam
- pkgver = 0.24.0
+ pkgver = 0.29.0
pkgrel = 1
url = https://github.com/AdguardTeam/dnsproxy
arch = x86_64
@@ -8,9 +8,11 @@ pkgbase = dnsproxy-adguard
makedepends = go
makedepends = git
source = dnsproxy-adguard.service
- source = https://github.com/AdguardTeam/dnsproxy/archive/v0.24.0.tar.gz
+ source = dnsproxy-adguard@.service
+ source = https://github.com/AdguardTeam/dnsproxy/archive/v0.29.0.tar.gz
sha256sums = e10bee304ce60088e523b0925c85a7c0640eaf4b2a686d301de565290e70560a
- sha256sums = 6b12caa51e797aa5bb8da219dd4db831ca680e8811de92859250b71d0bbf282a
+ sha256sums = 0e4083e1fa627a07e0ca92195c8a5181020ca567b9ffd8cd4f6c9e6a7fe35fa4
+ sha256sums = c091e04d71abdf1f9abe88b98e0ef66ddee9ff44c38f1b70a7be592d2a563ac3
pkgname = dnsproxy-adguard
diff --git a/PKGBUILD b/PKGBUILD
index 4ae4d4e50a91..3f9e40d68538 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,19 @@
_projectname=dnsproxy
pkgname=dnsproxy-adguard
-pkgver=0.24.0
+pkgver=0.29.0
pkgrel=1
pkgdesc="Simple DNS proxy with DoH, DoT, and DNSCrypt support by AdguardTeam"
arch=('x86_64')
url="https://github.com/AdguardTeam/dnsproxy"
license=('Apache')
source=("dnsproxy-adguard.service"
- "https://github.com/AdguardTeam/dnsproxy/archive/v${pkgver}.tar.gz")
+ "dnsproxy-adguard@.service"
+ "https://github.com/AdguardTeam/dnsproxy/archive/v${pkgver}.tar.gz")
makedepends=("go" "git")
sha256sums=('e10bee304ce60088e523b0925c85a7c0640eaf4b2a686d301de565290e70560a'
- '6b12caa51e797aa5bb8da219dd4db831ca680e8811de92859250b71d0bbf282a')
+ '0e4083e1fa627a07e0ca92195c8a5181020ca567b9ffd8cd4f6c9e6a7fe35fa4'
+ 'c091e04d71abdf1f9abe88b98e0ef66ddee9ff44c38f1b70a7be592d2a563ac3')
build(){
cd "${srcdir}/${_projectname}-${pkgver}"
@@ -23,4 +25,5 @@ package() {
cd "${srcdir}/${_projectname}-${pkgver}"
install -Dm755 dnsproxy "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 "${srcdir}/dnsproxy-adguard.service" "${pkgdir}/usr/lib/systemd/system/dnsproxy-adguard.service"
+ install -Dm644 "${srcdir}/dnsproxy-adguard@.service" "${pkgdir}/usr/lib/systemd/system/dnsproxy-adguard@.service"
}
diff --git a/dnsproxy-adguard@.service b/dnsproxy-adguard@.service
new file mode 100644
index 000000000000..e0e67e7c6bf2
--- /dev/null
+++ b/dnsproxy-adguard@.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Simple DNS proxy with DoH, DoT, and DNSCrypt support by AdguardTeam
+After=network.target
+
+[Service]
+Type=simple
+User=nobody
+Group=nobody
+ExecStart=/usr/bin/dnsproxy-adguard -l 127.0.0.1 -p %i -u tls://8.8.8.8 -u tls://8.8.4.4 -u https://mozilla.cloudflare-dns.com/dns-query -u https://dns.adguard.com/dns-query -u tls://9.9.9.9 -u tls://dns.adguard.com --cache --all-servers
+
+[Install]
+WantedBy=default.target