summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Wolsieffer2016-12-30 16:41:23 -0500
committerBen Wolsieffer2016-12-30 16:41:23 -0500
commit3158b90eabb7a1ae806aaaa4bc0bacec5ace70e1 (patch)
tree102b0dc021e9cb5c6c7c0d0c614d025946ef7231
parentc9d71d269137304e21d53b106e105f1c6b58a254 (diff)
downloadaur-3158b90eabb7a1ae806aaaa4bc0bacec5ace70e1.tar.gz
Update to 0.2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 949e59e95877..2dee1a4c318f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
# Generated by mksrcinfo v8
-# Tue Dec 13 20:55:47 UTC 2016
+# Fri Dec 30 21:41:15 UTC 2016
pkgbase = dnsupdate
pkgdesc = A modern and flexible dynamic DNS client
- pkgver = 0.1
- pkgrel = 2
+ pkgver = 0.2
+ pkgrel = 1
url = https://github.com/lopsided98/dnsupdate
arch = any
license = GPL3
makedepends = python-setuptools
+ makedepends = python-sphinx
+ makedepends = python-sphinx-argparse
depends = python-requests
depends = python-yaml
optdepends = python-beautifulsoup4: router address scraping
optdepends = python-netifaces: local interface address support
- provides = dnsupdate
conflicts = dnsupdate-git
- source = dnsupdate::git+https://github.com/lopsided98/dnsupdate.git#tag=0.1
+ source = dnsupdate::git+https://github.com/lopsided98/dnsupdate.git#tag=0.2
sha256sums = SKIP
pkgname = dnsupdate
diff --git a/PKGBUILD b/PKGBUILD
index a4f0971cdff6..3f4feef0f7ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,32 @@
# Maintainer: Ben Wolsieffer <benwolsieffer@gmail.com>
_github_url=https://github.com/lopsided98/dnsupdate
pkgname=dnsupdate
-pkgver=0.1
-pkgrel=2
+pkgver=0.2
+pkgrel=1
pkgdesc="A modern and flexible dynamic DNS client"
arch=('any')
url="${_github_url}"
license=('GPL3')
depends=('python-requests' 'python-yaml')
-makedepends=('python-setuptools')
+makedepends=(
+ 'python-setuptools'
+ 'python-sphinx'
+ 'python-sphinx-argparse'
+)
optdepends=(
'python-beautifulsoup4: router address scraping'
'python-netifaces: local interface address support'
)
conflicts=('dnsupdate-git')
-provides=('dnsupdate')
-source=(${pkgname}::git+${_github_url}.git#tag=$pkgver)
+source=(${pkgname}::git+${_github_url}.git#tag=${pkgver})
sha256sums=('SKIP')
build() {
cd "${srcdir}/${pkgname}"
python setup.py build
+
+ # Build man pages
+ python setup.py build_docs -b man
}
package() {
@@ -29,6 +35,10 @@ package() {
python setup.py install --skip-build --root="${pkgdir}" --optimize=1
install -Dm644 dnsupdate.service -t "${pkgdir}/usr/lib/systemd/system/"
+
+ cd build/docs/man
+ install -Dm644 "dnsupdate.1" -t "${pkgdir}/usr/share/man/man1/"
+ install -Dm644 "dnsupdate.5" -t "${pkgdir}/usr/share/man/man5/"
}
# vim:set ts=4 sw=4 et: