summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Wolsieffer2016-12-12 19:36:51 -0500
committerBen Wolsieffer2016-12-12 19:36:51 -0500
commit482ae29fce793ae4779926dee63d46caa9ae2b3d (patch)
tree511fba7fcb1afd658eba8adeee6a930e4d2061aa
downloadaur-482ae29fce793ae4779926dee63d46caa9ae2b3d.tar.gz
Initial commit.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a53890ce1445
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Dec 13 00:36:39 UTC 2016
+pkgbase = dnsupdate-git
+ pkgver = 0.1.r0.gde81e54
+ pkgrel = 1
+ url = https://github.com/lopsided98/dnsupdate
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-requests
+ depends = python-yaml
+ optdepends = python-beautifulsoup4: router address scraping
+ optdepends = python-netifaces: local interface address support
+ source = dnsupdate-git::git+https://github.com/lopsided98/dnsupdate.git
+ sha256sums = SKIP
+
+pkgname = dnsupdate-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f097c9cb0f02
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Ben Wolsieffer <benwolsieffer@gmail.com>
+# A DRY template for creating a Python 3 only package that uses setuptools and
+# is available on GitHub.
+
+_github_url=https://github.com/lopsided98/dnsupdate
+pkgname=dnsupdate-git
+pkgver=0.1.r0.gde81e54
+pkgrel=1
+pkgdesc=""
+arch=('any')
+url="${_github_url}"
+license=('GPL3')
+groups=()
+depends=('python-requests' 'python-yaml')
+makedepends=('python-setuptools')
+optdepends=(
+ 'python-beautifulsoup4: router address scraping'
+ 'python-netifaces: local interface address support'
+)
+source=(${pkgname}::git+${_github_url}.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+}
+
+# vim:set ts=4 sw=4 et: