summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Brost2018-01-23 21:46:36 +0100
committerJulian Brost2018-01-23 21:52:11 +0100
commitd2eaf97a92152c525ed9bf173249e088a85bdcee (patch)
treed1632e2b82120a69acc3c8a0577981e9fc70fd2a
downloadaur-d2eaf97a92152c525ed9bf173249e088a85bdcee.tar.gz
intial version 0.6.7-1
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD26
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd78d4970979
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = dnsviz
+ pkgdesc = Tool suite for analysis and visualization of DNS and DNSSEC
+ pkgver = 0.6.7
+ pkgrel = 1
+ url = https://github.com/dnsviz/dnsviz
+ arch = any
+ license = GPL
+ depends = python2
+ depends = python2-dnspython
+ depends = python2-pygraphviz
+ depends = python2-m2crypto
+ optdepends = python2-libnacl: verify ed25519 signatures
+ optdepends = bind: needed for some options involving zone files
+ options = !emptydirs
+ source = https://github.com/dnsviz/dnsviz/releases/download/v0.6.7/dnsviz-0.6.7-js.tar.gz
+ source = https://github.com/dnsviz/dnsviz/releases/download/v0.6.7/dnsviz-0.6.7-js.tar.gz.asc
+ validpgpkeys = 048D0B43891D7E7BCCAAEF011ED2ED92118571E6
+ sha256sums = 34d4583fd01b9fc6de82ef94560cb52fbe8388e33392feee65e633211b031136
+ sha256sums = SKIP
+
+pkgname = dnsviz
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9495a21ad32e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+/*.log
+*.swp
+/*.tar
+/*.asc
+/*.tar.gz
+/*.tar.xz
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..faf171004fac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Julian Brost <julian@0x4a42.net>
+
+pkgname=dnsviz
+pkgver=0.6.7
+pkgrel=1
+pkgdesc="Tool suite for analysis and visualization of DNS and DNSSEC"
+arch=('any')
+url="https://github.com/dnsviz/dnsviz"
+license=('GPL')
+depends=('python2' 'python2-dnspython' 'python2-pygraphviz' 'python2-m2crypto')
+optdepends=('python2-libnacl: verify ed25519 signatures'
+ 'bind: needed for some options involving zone files')
+options=(!emptydirs)
+source=("https://github.com/dnsviz/dnsviz/releases/download/v0.6.7/dnsviz-$pkgver-js.tar.gz"
+ "https://github.com/dnsviz/dnsviz/releases/download/v0.6.7/dnsviz-$pkgver-js.tar.gz.asc")
+sha256sums=('34d4583fd01b9fc6de82ef94560cb52fbe8388e33392feee65e633211b031136'
+ 'SKIP')
+validpgpkeys=(# Casey Deccio <casey@deccio.net>
+ '048D0B43891D7E7BCCAAEF011ED2ED92118571E6')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: