summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThor772016-01-02 17:03:29 +0100
committerThor772016-01-02 17:03:29 +0100
commit8de3589c0da41b6e7470a40e0eb4fc563238d07a (patch)
tree6421511833d49409249b94a5a0df4019486d7836
parent2ff4d85660a1954d1da229f664472b27d9d50bfc (diff)
downloadaur-8de3589c0da41b6e7470a40e0eb4fc563238d07a.tar.gz
fix outdated stuff
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD46
-rw-r--r--dnswalk.patch14
-rw-r--r--makereports.patch8
4 files changed, 38 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62f219941db4..d4de8113372f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jan 2 15:13:39 UTC 2016
+# Sat Jan 2 15:54:09 UTC 2016
pkgbase = dnswalk
pkgdesc = dnswalk is a DNS debugger
pkgver = 2.0.2
@@ -10,7 +10,11 @@ pkgbase = dnswalk
license = GPL
depends = perl-net-dns
source = http://heanet.dl.sourceforge.net/sourceforge/dnswalk/dnswalk-2.0.2.tar.gz
+ source = dnswalk.patch
+ source = makereports.patch
md5sums = 62b9302822353fad71d51aefdae1cad1
+ md5sums = e3cde1f934cf4ffc815453640efdad5c
+ md5sums = 02778b076ed29d2a46d27e0d2513a8f3
pkgname = dnswalk
diff --git a/PKGBUILD b/PKGBUILD
index 01e1442610fa..7544d77e0c6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
+# Maintainer: Thor77 <thor77 at thor77 dot org>
+
pkgname=dnswalk
pkgver=2.0.2
pkgrel=1
-pkgdesc="dnswalk is a DNS debugger"
-url="http://sourceforge.net/projects/dnswalk/"
-license="GPL"
+pkgdesc="dnswalk is a DNS debugger"
+url="http://sourceforge.net/projects/dnswalk/"
+license="GPL"
arch=(i686 x86_64)
-depends=('perl-net-dns')
-source=(http://heanet.dl.sourceforge.net/sourceforge/dnswalk/dnswalk-2.0.2.tar.gz)
-build() {
- cd $startdir/src/
- patch -p1 < $startdir/dnswalk.patch
- mkdir -p $startdir/pkg/usr/bin
- mkdir -p $startdir/pkg/usr/man/man1
- mkdir -p $startdir/pkg/usr/share/doc/dnswalk
- cp dnswalk $startdir/pkg/usr/bin
- cp do-dnswalk $startdir/pkg/usr/share/doc/dnswalk
- cp CHANGES $startdir/pkg/usr/share/doc/dnswalk
- cp README $startdir/pkg/usr/share/doc/dnswalk
- cp TODO $startdir/pkg/usr/share/doc/dnswalk
- cp rfc1912.txt $startdir/pkg/usr/share/doc/dnswalk
- cp makereports $startdir/pkg/usr/share/doc/dnswalk
- cp sendreports $startdir/pkg/usr/share/doc/dnswalk
- cp dnswalk.1 $startdir/pkg/usr/man/man1
- cp dnswalk.errors $startdir/pkg/usr/share/doc/dnswalk
- }
-md5sums=('62b9302822353fad71d51aefdae1cad1')
+depends=('perl-net-dns')
+source=('http://heanet.dl.sourceforge.net/sourceforge/dnswalk/dnswalk-2.0.2.tar.gz' 'dnswalk.patch' 'makereports.patch')
+md5sums=('62b9302822353fad71d51aefdae1cad1' 'e3cde1f934cf4ffc815453640efdad5c' '02778b076ed29d2a46d27e0d2513a8f3')
+
+prepare() {
+ cd $srcdir
+ patch dnswalk dnswalk.patch
+ patch makereports makereports.patch
+}
+package() {
+ cd $srcdir
+ mkdir -p $pkgdir/usr/bin
+ cp {do-,}dnswalk $pkgdir/usr/bin/
+ mkdir -p $pkgdir/usr/share/doc/dnswalk
+ cp {CHANGES,README,TODO,rfc1912.txt,makereports,sendreports,dnswalk.errors} $pkgdir/usr/share/doc/dnswalk/
+ mkdir -p $pkgdir/usr/man/man1
+ cp dnswalk.1 $pkgdir/usr/man/man1/
+}
diff --git a/dnswalk.patch b/dnswalk.patch
index 9f92cb6537c7..0d5164396ed8 100644
--- a/dnswalk.patch
+++ b/dnswalk.patch
@@ -1,18 +1,8 @@
-diff -ruN dnswalk.orig/dnswalk dnswalk/dnswalk
---- dnswalk.orig/dnswalk 2008-10-17 15:38:25.000000000 +0200
-+++ dnswalk/dnswalk 2008-10-17 15:38:36.000000000 +0200
+--- dnswalk 2016-01-02 16:30:41.569712858 +0100
++++ dnswalk.patched 2016-01-02 16:31:13.288934266 +0100
@@ -1,4 +1,4 @@
-#!/usr/contrib/bin/perl
+#!/usr/bin/perl
#
# dnswalk Walk through a DNS tree, pulling out zone data and
# dumping it in a directory tree
-diff -ruN dnswalk.orig/makereports dnswalk/makereports
---- dnswalk.orig/makereports 2008-10-17 15:38:25.000000000 +0200
-+++ dnswalk/makereports 2008-10-17 15:38:44.000000000 +0200
-@@ -1,4 +1,4 @@
--#!/usr/contrib/bin/perl
-+#!/usr/bin/perl
- # This takes output from dnswalk and makes a "rep.orts" directory
- # with one file per contact. Great for sending mail to all the admins.
-
diff --git a/makereports.patch b/makereports.patch
new file mode 100644
index 000000000000..e560658cf3b6
--- /dev/null
+++ b/makereports.patch
@@ -0,0 +1,8 @@
+--- makereports 2016-01-02 16:30:43.749659349 +0100
++++ makereports.patched 2016-01-02 16:34:34.943984164 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/contrib/bin/perl
++#!/usr/bin/perl
+ # This takes output from dnswalk and makes a "rep.orts" directory
+ # with one file per contact. Great for sending mail to all the admins.
+