summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkenshen1122020-05-05 15:56:13 -0700
committerkenshen1122020-05-05 15:58:27 -0700
commit98ebcd87d89656ad6a931362ae2a7adebf889ffe (patch)
treebba21f725b2e5a982f2cee653ba06462cf0e53af
downloadaur-98ebcd87d89656ad6a931362ae2a7adebf889ffe.tar.gz
Inital Commit to DobieSation. An upcoming ps2 emulator. I hope this PKGBUILD file is correct
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc060f3d61e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dobiestation
+ pkgdesc = A Dog based emulator for the ps2
+ pkgver = e4b4313be82ca341c862308ebe466b473d5acef9
+ pkgrel = 1
+ url = https://github.com/PSI-Rockin/DobieStation/
+ arch = x86_64
+ license = GPL
+ makedepends = gcc
+ makedepends = cmake
+ makedepends = git
+ depends = qt5-base
+ provides = dobiestation
+ conflicts = dobiestation
+ replaces = dobiestation
+
+pkgname = dobiestation
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6049e8056752
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=dobiestation
+pkgrel=1
+pkgver=e4b4313be82ca341c862308ebe466b473d5acef9
+pkgdesc='A Dog based emulator for the ps2'
+arch=(x86_64)
+url=https://github.com/PSI-Rockin/DobieStation/
+license=('GPL')
+groups=()
+depends=(qt5-base)
+makedepends=(
+gcc
+cmake
+git
+)
+provides=(dobiestation)
+conflicts=(dobiestation)
+replaces=(dobiestation)
+
+prepare()
+{
+ git clone https://github.com/PSI-Rockin/DobieStation.git
+ cd DobieStation
+ mkdir build && cd build
+ cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo
+}
+
+build() {
+ cd DobieStation && cd build
+ make
+}
+
+package() {
+ cd DobieStation && cd build
+ sudo make install
+} \ No newline at end of file