summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2024-02-15 14:20:01 +0100
committerKlaus Alexander Seistrup2024-02-15 14:20:01 +0100
commit2f2ca3643ecfe91588891470acd80820d3238ed8 (patch)
tree3428f3a41cade5fdfeb32fa365f3b9c33423e422
parent0911a0633e2fc0d9a0ed8f3bd34e9ff7779218bc (diff)
downloadaur-2f2ca3643ecfe91588891470acd80820d3238ed8.tar.gz
New upstream release: v2.2.0
Release notes: * https://github.com/darrenldl/docfd/releases/tag/2.2.0 Changes: * https://github.com/darrenldl/docfd/compare/2.1.0...2.2.0 ---- AUR: * Added docfd-bin.changelog to package
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
-rw-r--r--docfd-bin.changelog23
3 files changed, 32 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ebbd25e2263..9b4149bbbb33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = docfd-bin
pkgdesc = TUI multiline fuzzy document finder (pre-compiled)
- pkgver = 2.1.0
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/darrenldl/docfd
+ changelog = docfd-bin.changelog
arch = x86_64
license = MIT
provides = docfd
conflicts = docfd
- source = https://github.com/darrenldl/docfd/releases/download/2.1.0/docfd-2.1.0-ubuntu-latest.tar.gz
+ source = https://github.com/darrenldl/docfd/releases/download/2.2.0/docfd-2.2.0-ubuntu-latest.tar.gz
source = https://raw.githubusercontent.com/darrenldl/docfd/main/CHANGELOG.md
source = https://raw.githubusercontent.com/darrenldl/docfd/main/LICENSE
source = https://raw.githubusercontent.com/darrenldl/docfd/main/README.md
- sha256sums = 050c1f348534001a2a3c9923ec0a78430e6683af96ad332ced714f646b7705a8
+ sha256sums = c5f1def0ef7b29b8ae3e3ed86ae9cb24eb5788ba408d612ca6251093e7f98d3a
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- b2sums = 13ae443f5e8b467c4254f43713cd5ace023c083e9aec94bcc70c3c24d58c68fd5a23474c73141fb5517e10d5ae62a0009e4142a042831bd192eb2dc9d69d7ab8
+ b2sums = 618773aa746ee4ea3f8a7b1f99d9a3fbd5ce54499b1b2db63db7150a894a17bf723cbdff90a347ba1c524d95f2c1d0ce32dd74800891d29a56fd1af084e38739
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c07c087e19cb..746315face60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='docfd-bin'
_pkgname="${pkgname/-bin/}"
_flavour='ubuntu-latest'
-pkgver=2.1.0
+pkgver=2.2.0
pkgrel=1
pkgdesc='TUI multiline fuzzy document finder (pre-compiled)'
arch=('x86_64')
@@ -19,6 +19,7 @@ source=(
"$_rawurl/LICENSE"
"$_rawurl/README.md"
)
+changelog="$pkgname.changelog"
package() {
install -Dm0755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
@@ -30,11 +31,11 @@ package() {
}
sha256sums=(
- '050c1f348534001a2a3c9923ec0a78430e6683af96ad332ced714f646b7705a8'
+ 'c5f1def0ef7b29b8ae3e3ed86ae9cb24eb5788ba408d612ca6251093e7f98d3a'
'SKIP' 'SKIP' 'SKIP'
)
b2sums=(
- '13ae443f5e8b467c4254f43713cd5ace023c083e9aec94bcc70c3c24d58c68fd5a23474c73141fb5517e10d5ae62a0009e4142a042831bd192eb2dc9d69d7ab8'
+ '618773aa746ee4ea3f8a7b1f99d9a3fbd5ce54499b1b2db63db7150a894a17bf723cbdff90a347ba1c524d95f2c1d0ce32dd74800891d29a56fd1af084e38739'
'SKIP' 'SKIP' 'SKIP'
)
diff --git a/docfd-bin.changelog b/docfd-bin.changelog
new file mode 100644
index 000000000000..67d9ddd9b604
--- /dev/null
+++ b/docfd-bin.changelog
@@ -0,0 +1,23 @@
+## 2.2.0
+
+- Restored behaviour of skipping file extension checks for top-level
+ user specified files. This behaviour was likely removed during some
+ previous overhaul.
+
+ - This means, for instance, `docfd bin/docfd.ml` will now open the file
+ just fine without `--add-exts ml`
+
+- Bumped default max word search distance from 20 to 50
+
+- Added consideration for balanced opening closing symbols in search result ranking
+
+ - Namely symbol pairs: `()`, `[]`, `{}`
+
+- Fixed crash from reading from stdin
+
+ - This was caused by calling `Notty_unix.Term.release` after closing the underlying
+ file descriptor in stdin input mode
+
+- Added back handling of optional operator `?` in search expression
+
+- Added test corpus to check translation of search expression to search phrases