summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2024-03-12 13:38:13 +0100
committerKlaus Alexander Seistrup2024-03-12 13:38:13 +0100
commit312e578e600b01b395ad0d3b71b857d33c6085c6 (patch)
treefbd924f192f0c4ca78df42e624fa2681f621c71b
parent2f2ca3643ecfe91588891470acd80820d3238ed8 (diff)
downloadaur-312e578e600b01b395ad0d3b71b857d33c6085c6.tar.gz
New upstream release: v3.0.0
Release notes: * https://github.com/darrenldl/docfd/releases/tag/3.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--docfd-bin.changelog60
3 files changed, 53 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b4149bbbb33..4198bc58ac1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = docfd-bin
pkgdesc = TUI multiline fuzzy document finder (pre-compiled)
- pkgver = 2.2.0
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/darrenldl/docfd
changelog = docfd-bin.changelog
@@ -8,15 +8,15 @@ pkgbase = docfd-bin
license = MIT
provides = docfd
conflicts = docfd
- source = https://github.com/darrenldl/docfd/releases/download/2.2.0/docfd-2.2.0-ubuntu-latest.tar.gz
+ source = https://github.com/darrenldl/docfd/releases/download/3.0.0/docfd-3.0.0-ubuntu-latest.tar.gz
source = https://raw.githubusercontent.com/darrenldl/docfd/main/CHANGELOG.md
source = https://raw.githubusercontent.com/darrenldl/docfd/main/LICENSE
source = https://raw.githubusercontent.com/darrenldl/docfd/main/README.md
- sha256sums = c5f1def0ef7b29b8ae3e3ed86ae9cb24eb5788ba408d612ca6251093e7f98d3a
+ sha256sums = 9c767cfd958374747137308c81f697907a65d8ec011a3bfc95cbc075cb2522d1
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- b2sums = 618773aa746ee4ea3f8a7b1f99d9a3fbd5ce54499b1b2db63db7150a894a17bf723cbdff90a347ba1c524d95f2c1d0ce32dd74800891d29a56fd1af084e38739
+ b2sums = 1199f38a4f45b9e192c36a92fa5ec7442e9dd42bba05417b3dde250d36169ff6dc99343098a853429db6059d566dd29a95bc553a3308bf4d7dc80120f749301e
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 746315face60..61a38c7c32c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='docfd-bin'
_pkgname="${pkgname/-bin/}"
_flavour='ubuntu-latest'
-pkgver=2.2.0
+pkgver=3.0.0
pkgrel=1
pkgdesc='TUI multiline fuzzy document finder (pre-compiled)'
arch=('x86_64')
@@ -31,11 +31,11 @@ package() {
}
sha256sums=(
- 'c5f1def0ef7b29b8ae3e3ed86ae9cb24eb5788ba408d612ca6251093e7f98d3a'
+ '9c767cfd958374747137308c81f697907a65d8ec011a3bfc95cbc075cb2522d1'
'SKIP' 'SKIP' 'SKIP'
)
b2sums=(
- '618773aa746ee4ea3f8a7b1f99d9a3fbd5ce54499b1b2db63db7150a894a17bf723cbdff90a347ba1c524d95f2c1d0ce32dd74800891d29a56fd1af084e38739'
+ '1199f38a4f45b9e192c36a92fa5ec7442e9dd42bba05417b3dde250d36169ff6dc99343098a853429db6059d566dd29a95bc553a3308bf4d7dc80120f749301e'
'SKIP' 'SKIP' 'SKIP'
)
diff --git a/docfd-bin.changelog b/docfd-bin.changelog
index 67d9ddd9b604..ccc322d78451 100644
--- a/docfd-bin.changelog
+++ b/docfd-bin.changelog
@@ -1,23 +1,55 @@
-## 2.2.0
+## 3.0.0
-- Restored behaviour of skipping file extension checks for top-level
- user specified files. This behaviour was likely removed during some
- previous overhaul.
+- Fixed crash from search result snippet being bigger the content view pane
- - This means, for instance, `docfd bin/docfd.ml` will now open the file
- just fine without `--add-exts ml`
+ - Crash was from `Content_and_search_result_render.color_word_image_grid`
-- Bumped default max word search distance from 20 to 50
+- Added key bindings
-- Added consideration for balanced opening closing symbols in search result ranking
+ - `p`: exit and print search result to stderr
+ - `Shift+P`: exit and print file path to stderr
- - Namely symbol pairs: `()`, `[]`, `{}`
+- Changed `--debug-log -` to use stderr instead of stdout
-- Fixed crash from reading from stdin
+- Added non-interactive search mode where search results are printed to stdout
- - This was caused by calling `Notty_unix.Term.release` after closing the underlying
- file descriptor in stdin input mode
+ - `--search EXP` invokes non-interactive search mode with search expression `EXP`
+ - `--search-result-count-per-document` sets the number of top search results printed per document
+ - `--search-result-print-text-width` sets the text width to use when printing
-- Added back handling of optional operator `?` in search expression
+- Added `--start-with-search` to prefill the search field in interactive mode
-- Added test corpus to check translation of search expression to search phrases
+- Removed content requirement expression from multi-file view
+
+ - Originally designed for file filtering, but I have almost never used
+ it since its addition in 1.0.0
+
+- Added word based line wrapping to following components of document list in multi-file view
+
+ - Document title
+ - Document path
+ - Document content preview
+
+- Added word breaking in word based line wrapping logic so all of the original characters
+ are displayed even when the terminal width is very small or when a word/token is very long
+
+- Added `--paths-from` to specify a file containing list of paths to (also) be scanned
+
+- Fixed search result centering in presence of line wrapping
+
+- Renamed `--max-fuzzy-edit` to `--max-fuzzy-edit-dist` for consistency
+
+- Changed error messages to not be capitalized to follow Rust's and Go's
+ guidelines on error messages
+
+- Added fallback rendering text so Docfd does not crash from trying
+ to render invalid text.
+
+- Added pandoc integration
+
+- Changed the logic of determining when to use stdin as document source
+
+ - Now if any paths are specified, stdin is ignored
+ - This change mostly came from Dune's cram test mechanism
+ not providing a tty to stdin, so previously Docfd would keep
+ trying to source from stdin even when explicit paths are provided