summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2024-05-12 13:26:18 +0200
committerKlaus Alexander Seistrup2024-05-12 13:26:18 +0200
commit8deffd0b8d7d044f22799405ea1a9ef8627dff02 (patch)
tree6d4044aba92504ed25e2fac9a4098fe5ffbe5543
parent0be53ef2ae9f6015e03aaf8d2f7ce50a0f2c4871 (diff)
downloadaur-8deffd0b8d7d044f22799405ea1a9ef8627dff02.tar.gz
New upstream release: v6.0.0
Release notes: * https://github.com/darrenldl/docfd/releases/tag/6.0.0 * pacman -Qc docfd-bin
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--docfd-bin.changelog35
3 files changed, 38 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 693be23efb82..f1e934230790 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = docfd-bin
pkgdesc = TUI multiline fuzzy document finder (pre-compiled)
- pkgver = 5.1.0
+ pkgver = 6.0.0
pkgrel = 1
url = https://github.com/darrenldl/docfd
changelog = docfd-bin.changelog
@@ -8,15 +8,15 @@ pkgbase = docfd-bin
license = MIT
provides = docfd
conflicts = docfd
- source = https://github.com/darrenldl/docfd/releases/download/5.1.0/docfd-5.1.0-ubuntu-latest.tar.gz
+ source = https://github.com/darrenldl/docfd/releases/download/6.0.0/docfd-6.0.0-ubuntu-latest.tar.gz
source = https://raw.githubusercontent.com/darrenldl/docfd/main/CHANGELOG.md
source = https://raw.githubusercontent.com/darrenldl/docfd/main/LICENSE
source = https://raw.githubusercontent.com/darrenldl/docfd/main/README.md
- sha256sums = 52e6dd20ee7fbad8d56e636cfe24ef3beaef45911659725e4ffbdb16e6eaffff
+ sha256sums = 9979ef80e28d03be9cbde7387dcec850255b815135ae93cced9d6d65fcef9eb1
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- b2sums = 6f717ec4c79d0e0e547120dd2200a3288d60ec6d1651139a49e582ba8dd8dafa393bfe25194f39dc2de1a4bd5a29c6e07592c1c5b3cec968792b6173beb60ea6
+ b2sums = 8b7bc458da0d24de4e0fd36e85f850a2fb993f7704f85c60333ea75f05c36e2c7b39413cb235db70b8206d4c2b544adb4d2d7375fa4f6d941f9bd298a38abaa6
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 004db1191297..0ffe85cc9050 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# -*- sh -*-
pkgname='docfd-bin'
-_pkgname="${pkgname/-bin/}"
+_pkgname="${pkgname/-bin}"
_flavour='ubuntu-latest'
-pkgver=5.1.0
+pkgver=6.0.0
pkgrel=1
pkgdesc='TUI multiline fuzzy document finder (pre-compiled)'
arch=('x86_64')
@@ -30,11 +30,11 @@ package() {
}
sha256sums=(
- '52e6dd20ee7fbad8d56e636cfe24ef3beaef45911659725e4ffbdb16e6eaffff'
+ '9979ef80e28d03be9cbde7387dcec850255b815135ae93cced9d6d65fcef9eb1'
'SKIP' 'SKIP' 'SKIP'
)
b2sums=(
- '6f717ec4c79d0e0e547120dd2200a3288d60ec6d1651139a49e582ba8dd8dafa393bfe25194f39dc2de1a4bd5a29c6e07592c1c5b3cec968792b6173beb60ea6'
+ '8b7bc458da0d24de4e0fd36e85f850a2fb993f7704f85c60333ea75f05c36e2c7b39413cb235db70b8206d4c2b544adb4d2d7375fa4f6d941f9bd298a38abaa6'
'SKIP' 'SKIP' 'SKIP'
)
diff --git a/docfd-bin.changelog b/docfd-bin.changelog
index 97ac2671f21e..288865d6d58a 100644
--- a/docfd-bin.changelog
+++ b/docfd-bin.changelog
@@ -1,8 +1,33 @@
-## 5.1.0
+## 6.0.0
-- Fixed help message of `--max-token-search-dist`
+- Fixed help message of `--max-linked-token-search-dist`
-- Adjusted path display in UI to hide current working directory segment when
- applicable
+- Fixed search result printing where output gets chopped off if terminal width is too small
-- Added missing blinking for `Tab` key presses
+- Added smart additional line grabbing for search result printing
+
+ - `--search-result-print-snippet-min-size N`
+ - If the search result to be printed has fewer than `N` non-space tokens,
+ then Docfd tries to add surrounding lines to the snippet
+ to give better context.
+ - `--search-result-print-snippet-max-add-lines`
+ - Controls maximum number of surrounding lines that can be added in each direction.
+
+- Added search result underlining when output is not a terminal,
+ e.g. redirected to file, piped to another command
+
+- Changed `--search` to show all search results
+
+- Added `--sample` that uses `--search` previous behavior where (by default)
+ only a handful of top search results are picked for each document
+
+- Changed `--search-result-count-per-doc` to `--sample-count-per-doc`
+
+- Added `--color` and `--underline` for controlling behavior of search result
+ printing, they can take one of:
+
+ - `never`
+ - `always`
+ - `auto`
+
+- Removed blinking for `Tab` key presses