summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2024-05-05 10:21:33 +0200
committerKlaus Alexander Seistrup2024-05-05 10:21:33 +0200
commitd73f62a8f429bf2a3ae6c0183fa1d6e20d7fdcd6 (patch)
tree0d7ad629427ef7cab2bf54069dc2a5215923ff99
parent36e6d5b5b8d5e1d52ef6807ff6ba9f653856d75d (diff)
downloadaur-d73f62a8f429bf2a3ae6c0183fa1d6e20d7fdcd6.tar.gz
New upstream release: v5.0.0
Release notes: * https://github.com/darrenldl/docfd/releases/tag/5.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--docfd-bin.changelog39
3 files changed, 36 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40cb77fa77ee..02aed0a21d37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = docfd-bin
pkgdesc = TUI multiline fuzzy document finder (pre-compiled)
- pkgver = 4.0.0
+ pkgver = 5.0.0
pkgrel = 1
url = https://github.com/darrenldl/docfd
changelog = docfd-bin.changelog
@@ -8,15 +8,15 @@ pkgbase = docfd-bin
license = MIT
provides = docfd
conflicts = docfd
- source = https://github.com/darrenldl/docfd/releases/download/4.0.0/docfd-4.0.0-ubuntu-latest.tar.gz
+ source = https://github.com/darrenldl/docfd/releases/download/5.0.0/docfd-5.0.0-ubuntu-latest.tar.gz
source = https://raw.githubusercontent.com/darrenldl/docfd/main/CHANGELOG.md
source = https://raw.githubusercontent.com/darrenldl/docfd/main/LICENSE
source = https://raw.githubusercontent.com/darrenldl/docfd/main/README.md
- sha256sums = 17f2a1c1551e44dce286d41f12dc576d5b8293cdc9d07a7db0bb304bcd179fec
+ sha256sums = 393ad40ac58375d51f025d087e7c6bdcf9195b292741eee078cf4df69c69fee4
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- b2sums = 2eddbd3002c6e0673d16c15647b056b01382d5343b8e207e6a4794bc5a10f5bf1fbb331663e3b155b0c1e23ff63ed34d100f97571b93db6c0bb8713e087fc599
+ b2sums = 6ae79a5a52ebd2d4e2c3c2466fdccffae8ca11dac50cdcb10f84cffd606e39c7453be8500d27c955ba013600973a1fd0e1e24c3fe08a7ffacd3314049782d88f
b2sums = SKIP
b2sums = SKIP
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2c98ddb77558..764939285d1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='docfd-bin'
_pkgname="${pkgname/-bin/}"
_flavour='ubuntu-latest'
-pkgver=4.0.0
+pkgver=5.0.0
pkgrel=1
pkgdesc='TUI multiline fuzzy document finder (pre-compiled)'
arch=('x86_64')
@@ -22,20 +22,19 @@ source=(
changelog="$pkgname.changelog"
package() {
- install -Dm0755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
- install -Dm0644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-
- for _doc in {CHANGELOG,README}.md; do
- install -Dm0644 "$_doc" "$pkgdir/usr/share/docs/$pkgname/$_doc"
- done
+ install -vDm0755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -vDm0644 -t "$pkgdir/usr/share/docs/$pkgname/" \
+ {CHANGELOG,README}.md
+ install -vDm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" \
+ LICENSE
}
sha256sums=(
- '17f2a1c1551e44dce286d41f12dc576d5b8293cdc9d07a7db0bb304bcd179fec'
+ '393ad40ac58375d51f025d087e7c6bdcf9195b292741eee078cf4df69c69fee4'
'SKIP' 'SKIP' 'SKIP'
)
b2sums=(
- '2eddbd3002c6e0673d16c15647b056b01382d5343b8e207e6a4794bc5a10f5bf1fbb331663e3b155b0c1e23ff63ed34d100f97571b93db6c0bb8713e087fc599'
+ '6ae79a5a52ebd2d4e2c3c2466fdccffae8ca11dac50cdcb10f84cffd606e39c7453be8500d27c955ba013600973a1fd0e1e24c3fe08a7ffacd3314049782d88f'
'SKIP' 'SKIP' 'SKIP'
)
diff --git a/docfd-bin.changelog b/docfd-bin.changelog
index 9e4e7a1a828c..ed864650e269 100644
--- a/docfd-bin.changelog
+++ b/docfd-bin.changelog
@@ -1,24 +1,33 @@
-## 4.0.0
+## 5.0.0
-- Made document search asynchronous to search field input, so UI remains
- smooth even if search is slow
+- Added file globbing support in the form of `--glob` argument
-- Added status to search bar:
+- Added single line search mode arguments
- - `OK` means Docfd is idling
- - `...` means Docfd is searching
- - `ERR` means Docfd failed to parse the search expression
+ - `--single-line-exts`
+ - `--single-line-add-exts`
+ - `--single-line-glob`
+ - `--single-line`
-- Added search cancellation. Triggered by editing or clearing search field.
+- Fixed crash on empty file
-- Added dynamic search distance adjustment based on notion of linked tokens
+ - This was due to assertion failure of `max_line_num` in
+ `Content_and_search_result_render.content_snippet`
- - Two tokens are linked if there is no space between them,
- e.g. `-` and `>` are linked in `->`, but not in `- >`
+- Changed search result printing via `Shift+P` and `p` within TUI to not exit
+ after printing, allowing printing of more results
-- Replaced `word` with `token` in the following options for consistency
+- Added blinking to key binding info grid to give better visual feedback,
+ especially for the new behavior of search result printing
- - `--max-word-search-dist`
- - `--index-chunk-word-count`
+- Changed to allow `--paths-from` to be specified multiple times
-- Replaced `word` with `token` in user-facing text
+- Fixed handling of `.htm` files
+
+ - `htm` is not a valid value for pandoc's `--format` argument
+ - Now it is rewritten to `html` before being passed to pandoc
+
+- Changed `--max-depth`:
+
+ - Changed default from 10 to 100
+ - Changed to accept 0