summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmlb2017-11-19 17:53:11 +0100
committersmlb2017-11-19 17:53:11 +0100
commitbf3a43af9ba57bc20e5b740805e483ae55152746 (patch)
tree24a0e33d36dbe763c202781a2b15b075effdb8c6
parent6efdb628132c396e14b47ecd30ecc6168ae26ecd (diff)
downloadaur-bf3a43af9ba57bc20e5b740805e483ae55152746.tar.gz
pkgbuild: clean
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b068c19dfcaf..de98de7b223d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = dockd
arch = i686
arch = x86_64
license = BSD-2
- depends = cmake
+ makedepends = cmake
depends = systemd
depends = libthinkpad
depends = libsystemd
diff --git a/PKGBUILD b/PKGBUILD
index f5d5be5f06db..7af0ceaf8f89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,8 @@ pkgdesc="Lenovo ThinkPad Dock Management Daemon"
arch=('i686' 'x86_64')
url="https://github.com/libthinkpad/dockd"
license=('BSD-2')
-depends=('cmake' 'systemd' 'libthinkpad' 'libsystemd' 'libxrandr')
+depends=('systemd' 'libthinkpad' 'libsystemd' 'libxrandr')
+makedepends=('cmake')
source=("http://thinkpads.org/ftp/$pkgname/$pkgname-$pkgver.tar.gz")
md5sums=('a3606e57095cd536d636edc7541af9f4')
@@ -23,8 +24,6 @@ build() {
package() {
cd "${srcdir}/${pkgname}-${pkgver}" || exit 1
- install -Dm644 ./${pkgname}.desktop -t "${pkgdir}"/etc/xdg/autostart
- install -Dm755 ./dockd "$pkgdir/usr/bin/$pkgname"
install -Dm755 -d etc "$pkgdir/etc/$pkgname"
+ make DESTDIR=$pkgdir install
}
-