summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmlb2017-11-19 13:00:29 +0100
committersmlb2017-11-19 13:00:29 +0100
commitda289078e4639f4279a22e7717456b05fbb9349e (patch)
treec278f8e6b72eb12ae157985a98379f57a827f6d4
downloadaur-da289078e4639f4279a22e7717456b05fbb9349e.tar.gz
dockd: first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dbb17630ba0f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dockd
+ pkgdesc = A general purpose userspace ThinkPad library
+ pkgver = 1.20
+ pkgrel = 2
+ url = https://github.com/libthinkpad/dockd
+ arch = i686
+ arch = x86_64
+ license = BSD-2
+ depends = cmake
+ depends = systemd
+ depends = libthinkpad
+ depends = libsystemd
+ depends = libxrandr
+ source = http://thinkpads.org/ftp/dockd/dockd-1.20.tar.gz
+ md5sums = a3606e57095cd536d636edc7541af9f4
+
+pkgname = dockd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0de54e6a2c00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: smlb <smlb at riseup dot net>
+
+pkgname=dockd
+pkgver=1.20
+pkgrel=2
+pkgdesc="A general purpose userspace ThinkPad library"
+arch=('i686' 'x86_64')
+url="https://github.com/libthinkpad/dockd"
+license=('BSD-2')
+depends=('cmake' 'systemd' 'libthinkpad' 'libsystemd' 'libxrandr')
+source=("http://thinkpads.org/ftp/$pkgname/$pkgname-$pkgver.tar.gz")
+md5sums=('a3606e57095cd536d636edc7541af9f4')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}" || exit 1
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+ install -Dm755 ./dockd "$pkgdir/usr/bin/$pkgname"
+}
+