summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmytro Aleksandrov2015-06-25 10:10:29 +0300
committerDmytro Aleksandrov2015-06-25 10:11:56 +0300
commitcb6d660b0f2edaccb2b5c2bda196a40b4d269384 (patch)
tree4b1ef716b462ca6eefc4b255bbcaef8f6f7669fb
downloadaur-cb6d660b0f2edaccb2b5c2bda196a40b4d269384.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD29
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cecfd35d72d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = docker-compose-bin
+ pkgdesc = Fast, isolated development environments using Docker
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://www.docker.com/
+ arch = x86_64
+ license = Apache
+ depends = docker
+ conflicts = docker-compose
+ options = !strip
+ source = https://github.com/docker/compose/releases/download/1.3.1/docker-compose-Linux-x86_64
+ source = https://github.com/docker/compose/archive/1.3.1.tar.gz
+ sha256sums = 1ceb5fd0d43bc7ae33eb9c78779e43ed89b4dba16375bbce09c8dce770c7d73d
+ sha256sums = 04b60b805dc305543d5fe9a0880b8e1ad5818c440587a26b0eb01f9e3e8e79eb
+
+pkgname = docker-compose-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f2f9c8e7d603
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!.SRCINFO
+!PKGBUILD \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aaeaf417ae27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+#Maintainer: Dmytro Aleksandrov <alkersan@gmail.com>
+
+pkgname=docker-compose-bin
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Fast, isolated development environments using Docker"
+depends=('docker')
+arch=('x86_64')
+conflicts=('docker-compose')
+options=(!strip)
+source=(
+ "https://github.com/docker/compose/releases/download/$pkgver/docker-compose-Linux-x86_64"
+ "https://github.com/docker/compose/archive/$pkgver.tar.gz"
+)
+url="https://www.docker.com/"
+license="Apache"
+sha256sums=('1ceb5fd0d43bc7ae33eb9c78779e43ed89b4dba16375bbce09c8dce770c7d73d'
+ '04b60b805dc305543d5fe9a0880b8e1ad5818c440587a26b0eb01f9e3e8e79eb')
+
+package() {
+ cd $srcdir
+ install -Dm755 docker-compose-Linux-x86_64 $pkgdir/usr/bin/docker-compose
+ ln -s /usr/bin/docker-compose $pkgdir/usr/bin/fig
+
+ cd $srcdir/compose-$pkgver
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 contrib/completion/bash/docker-compose $pkgdir/etc/bash_completion.d/docker-compose
+ install -Dm644 contrib/completion/zsh/_docker-compose $pkgdir/usr/share/zsh/site-functions/_docker-compose
+} \ No newline at end of file