summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Weißschuh2021-06-10 08:55:48 +0200
committerThomas Weißschuh2021-06-10 08:55:48 +0200
commitf36c553cb68caadf4f038162903b53e990d6b668 (patch)
tree6f1c425e0fbdbdb3a2375f733bd92000e7e0f31c
downloadaur-f36c553cb68caadf4f038162903b53e990d6b668.tar.gz
Initial upload: docker-compose-cli 1.0.17-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD45
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d45e5e4a943
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = docker-compose-cli
+ pkgdesc = Easily run your Compose application to the cloud with compose-cli
+ pkgver = 1.0.17
+ pkgrel = 1
+ url = https://github.com/docker/compose-cli
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ source = https://github.com/docker/compose-cli/archive/refs/tags/v1.0.17.tar.gz
+ sha256sums = f931053d7a654c8b321dad4d397f36a60df6034d01cea7b9662859f45ae9e048
+
+pkgname = docker-compose-cli
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..200f34d449c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Thomas Weißschuh <aur t-8ch de>
+
+pkgname=docker-compose-cli
+pkgver=1.0.17
+pkgrel=1
+pkgdesc="Easily run your Compose application to the cloud with compose-cli"
+arch=('x86_64')
+url="https://github.com/docker/compose-cli"
+license=(Apache)
+source=("https://github.com/docker/compose-cli/archive/refs/tags/v${pkgver}.tar.gz")
+makedepends=('go')
+sha256sums=('f931053d7a654c8b321dad4d397f36a60df6034d01cea7b9662859f45ae9e048')
+
+prepare(){
+ cd "compose-cli-$pkgver"
+
+ sed -i 's#com.docker.cli#docker#' \
+ cli/mobycli/exec.go \
+ api/context/store/storedefault.go
+
+ mkdir -p build/
+}
+
+build() {
+ cd "compose-cli-$pkgver"
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build ./cli/...
+}
+
+check() {
+ cd "compose-cli-$pkgver"
+
+# go test ./...
+}
+
+package() {
+ cd "compose-cli-$pkgver"
+
+ install -Dm755 build/cli "$pkgdir"/usr/bin/$pkgname
+}