summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornfnty2015-06-08 17:51:20 +0200
committernfnty2015-06-08 17:51:20 +0200
commit55cd82b77c2fdbaf2d29ec4bf465c6b0ea2ac28f (patch)
treeb4411742caae6df905b9dca1b9b5a673d372643d
downloadaur-55cd82b77c2fdbaf2d29ec4bf465c6b0ea2ac28f.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD56
-rw-r--r--version.patch17
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3484d2b987bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = docker-compose-git
+ pkgdesc = Define and run complex applications using Docker
+ pkgver = r1
+ pkgrel = 1
+ url = https://github.com/docker/compose
+ arch = any
+ license = Apache
+ makedepends = git
+ depends = python
+ depends = python-docopt
+ depends = python-yaml
+ depends = python-requests
+ depends = python-texttable
+ depends = python-websocket-client
+ depends = python-docker-py
+ depends = python-dockerpty
+ depends = python-six
+ depends = python-setuptools
+ provides = docker-compose
+ conflicts = docker-compose
+ source = docker-compose::git+https://github.com/docker/compose.git#tag=1.2.0
+ source = version.patch
+ sha512sums = SKIP
+ sha512sums = d716f03591b720f178599bb9b4d3ac31d7fde4a20637d5edf626f517f159fd38dd3e47b1f8dfa303ff2523b54b729363c6be0b887c260581663b8e63e0005e43
+
+pkgname = docker-compose-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f21eb5549d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+pkgname=('docker-compose-git')
+srcname='docker-compose'
+pkgver='r1'
+pkgrel='1'
+pkgdesc='Define and run complex applications using Docker'
+arch=('any')
+url='https://github.com/docker/compose'
+license=('Apache')
+
+depends=(
+ 'python'
+ 'python-docopt'
+ 'python-yaml'
+ 'python-requests'
+ 'python-texttable'
+ 'python-websocket-client'
+ 'python-docker-py'
+ 'python-dockerpty'
+ 'python-six'
+ 'python-setuptools'
+)
+makedepends=('git')
+provides=('docker-compose')
+conflicts=('docker-compose')
+
+source=(
+ "${srcname}::git+https://github.com/docker/compose.git#tag=1.2.0"
+ 'version.patch'
+)
+sha512sums=(
+ 'SKIP'
+ 'd716f03591b720f178599bb9b4d3ac31d7fde4a20637d5edf626f517f159fd38dd3e47b1f8dfa303ff2523b54b729363c6be0b887c260581663b8e63e0005e43'
+)
+
+pkgver() {
+ cd "${srcdir}/${srcname}"
+
+ printf 'r%s.%s\n' \
+ "$( git rev-list HEAD | wc --lines )" \
+ "$( git describe --always | sed 's/-/./g' )"
+}
+
+prepare() {
+ cd "${srcdir}/${srcname}"
+
+ git apply "${srcdir}/version.patch"
+}
+
+package() {
+ cd "${srcdir}/${srcname}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ install -D --mode=644 LICENSE "${pkgdir}/usr/share/licenses/${srcname}/LICENSE"
+ install -D --mode=644 contrib/completion/bash/docker-compose "${pkgdir}/usr/share/bash-completion/completions/docker-compose"
+}
diff --git a/version.patch b/version.patch
new file mode 100644
index 000000000000..19ce8f73cdb6
--- /dev/null
+++ b/version.patch
@@ -0,0 +1,17 @@
+diff --git a/setup.py b/setup.py
+index a8f7d98..2f83873 100644
+--- a/setup.py
++++ b/setup.py
+@@ -27,10 +27,10 @@ def find_version(*file_paths):
+ install_requires = [
+ 'docopt >= 0.6.1, < 0.7',
+ 'PyYAML >= 3.10, < 4',
+- 'requests >= 2.2.1, < 2.6',
++ 'requests >= 2.6.1, < 2.7',
+ 'texttable >= 0.8.1, < 0.9',
+ 'websocket-client >= 0.11.0, < 1.0',
+- 'docker-py >= 1.0.0, < 1.2',
++ 'docker-py >= 1.2.0, < 1.3',
+ 'dockerpty >= 0.3.2, < 0.4',
+ 'six >= 1.3.0, < 2',
+ ]