summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerardo Gomez2022-08-14 14:57:45 +0200
committerGerardo Gomez2022-08-14 14:57:45 +0200
commit818c1a750c29fcb4c8a04352c52fb84e16e3c17c (patch)
tree30d242713695bbc2a47a048dcbd8b6e4d15ed69b
downloadaur-818c1a750c29fcb4c8a04352c52fb84e16e3c17c.tar.gz
install standalone docker-compose-v2
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD30
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8a0dbb5b472
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = docker-compose-v2-bin
+ pkgdesc = Standalone Golang-based package of a tool for running multi-container applications on Docker defined using the Compose file format
+ pkgver = 2.9.0
+ pkgrel = 1
+ url = https://github.com/docker/compose
+ arch = x86_64
+ license = Apache
+ provides = docker-compose
+ conflicts = docker-compose
+ options = !strip
+ source = docker-compose-v2.9.0::https://github.com/docker/compose/releases/download/v2.9.0/docker-compose-linux-x86_64
+ source = https://github.com/docker/compose/archive/v2.9.0.tar.gz
+ sha256sums = 3be9ce88ecba41b734e3fc8e59a9b11531133761414a78827d1615aadb5ef1f5
+ sha256sums = 582f3dacb3e96e9a07ff3b9d137b508377a769309b84f6faa8722d7f5a226353
+
+pkgname = docker-compose-v2-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..75bd249681c9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22521ee83ffb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Gerardo Gomez <gerardo.gomez@tutanota.com>
+
+pkgname=docker-compose-v2-bin
+pkgver=2.9.0
+pkgrel=1
+pkgdesc="Standalone Golang-based package of a tool for running multi-container applications on Docker defined using the Compose file format"
+depends=()
+arch=('x86_64')
+conflicts=('docker-compose')
+provides=('docker-compose')
+options=(!strip)
+source=(
+ "docker-compose-v$pkgver::https://github.com/docker/compose/releases/download/v$pkgver/docker-compose-linux-x86_64"
+ "https://github.com/docker/compose/archive/v$pkgver.tar.gz"
+)
+url="https://github.com/docker/compose"
+license=("Apache")
+sha256sums=('3be9ce88ecba41b734e3fc8e59a9b11531133761414a78827d1615aadb5ef1f5'
+ '582f3dacb3e96e9a07ff3b9d137b508377a769309b84f6faa8722d7f5a226353')
+
+package() {
+ cd "$srcdir"
+ install -Dm755 "docker-compose-v$pkgver" "$pkgdir/usr/bin/docker-compose"
+
+ cd "$srcdir/compose-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ # bash and zsh completion are missing, but there is a pending relevant PR: https://github.com/docker/compose/pull/9620/files
+ # install -Dm644 contrib/completion/bash/docker-compose "$pkgdir/etc/bash_completion.d/docker-compose"
+ # install -Dm644 contrib/completion/zsh/_docker-compose "$pkgdir/usr/share/zsh/site-functions/_docker-compose"
+}