summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien LEFEBVRE (d1ceward)2023-08-23 18:45:36 +0200
committerFabien LEFEBVRE (d1ceward)2023-08-23 18:45:36 +0200
commit0d250f68cf9baa177c9f1bb4dd159dfa1205fc1d (patch)
tree1b2d9912ccdc3486e3f75c5d35dd71a7f623d381
downloadaur-0d250f68cf9baa177c9f1bb4dd159dfa1205fc1d.tar.gz
Initial upload: docker-container-healthchecker 0.6.4-1
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD18
4 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f99f422d8f18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = docker-container-healthchecker
+ pkgdesc = Runs healthchecks against local docker containers
+ pkgver = 0.6.4
+ pkgrel = 1
+ url = https://github.com/dokku/docker-container-healthchecker
+ arch = x86_64
+ license = BSD
+ source = https://github.com/dokku/docker-container-healthchecker/releases/download/v0.6.4/docker-container-healthchecker_0.6.4_linux_amd64.tgz
+ source = LICENSE
+ sha256sums = fdf4af77dc3c63e6b6b9fc194d65e32beae6fc9822b669be5738b2803fd80a1c
+ sha256sums = d96d9cdac79ad3e8606579ddf99f16a72c5abe437b37810a061e4fcb38de05cc
+
+pkgname = docker-container-healthchecker
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f9ecc0a87e76
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.tgz
+/*.pkg.tar.zst
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..f001a3cf8ace
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,27 @@
+Copyright (c) 2019 Jose Diaz-Gonzalez. All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+ * Redistributions of source code must retain the above copyright
+notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above
+copyright notice, this list of conditions and the following disclaimer
+in the documentation and/or other materials provided with the
+distribution.
+ * Neither the name of Jose Diaz-Gonzalez nor the names of its
+contributors may be used to endorse or promote products derived from
+this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60a291a54210
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Fabien LEFEBVRE <contact@d1ceward.com>
+
+pkgname=docker-container-healthchecker
+pkgver=0.6.4
+pkgrel=1
+pkgdesc='Runs healthchecks against local docker containers'
+arch=('x86_64')
+url='https://github.com/dokku/docker-container-healthchecker'
+license=('BSD')
+source=("${url}/releases/download/v${pkgver}/${pkgname}_${pkgver}_linux_amd64.tgz"
+ 'LICENSE')
+sha256sums=('fdf4af77dc3c63e6b6b9fc194d65e32beae6fc9822b669be5738b2803fd80a1c'
+ 'd96d9cdac79ad3e8606579ddf99f16a72c5abe437b37810a061e4fcb38de05cc')
+
+package() {
+ install -Dm755 docker-container-healthchecker-amd64 "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}