summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nakhimovich2024-02-07 19:35:17 -0500
committerDaniel Nakhimovich2024-02-07 19:35:17 -0500
commit53e5c8b9d4fcd7997787da59be6e08973892b227 (patch)
treecfe2b950d21a7bcb914741f5fb63219ae52bb5fe
downloadaur-53e5c8b9d4fcd7997787da59be6e08973892b227.tar.gz
first
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD61
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..128f9c9825ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = docker-credential-secretservice
+ pkgdesc = Store docker credentials using the D-Bus Secret Service
+ pkgver = 0.8.1.r0.g292722b
+ pkgrel = 1
+ url = https://github.com/docker/docker-credential-helpers
+ arch = x86_64
+ arch = i686
+ arch = aarch64
+ license = MIT
+ makedepends = git
+ makedepends = go
+ depends = libsecret
+ source = git+https://github.com/docker/docker-credential-helpers
+ b2sums = SKIP
+
+pkgname = docker-credential-secretservice
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fcb51ed6b846
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+.gitignore
+*.tar.*
+.zst
+pkg/
+src/
+docker-credential-helpers/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b160ee5b304a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: DanielNak <daniel@tee.cat>
+# Contributor: Allen Wild <allenwild93@gmail.com>
+# Contributor: Alireza Ayinmehr <alireza.darksun@gmail.com>
+# Contributor: Abhishek Mukherjee <amukherjee@tripadvisor.com>
+
+_pkgname=docker-credential-helpers
+_author=docker
+pkgname=docker-credential-secretservice
+pkgver=0.8.1.r0.g292722b
+pkgrel=1
+pkgdesc="Store docker credentials using the D-Bus Secret Service"
+arch=(x86_64 i686 aarch64)
+url="https://github.com/docker/docker-credential-helpers"
+url="https://github.com/$_author/$_pkgname"
+license=('MIT')
+depends=('libsecret')
+makedepends=('git' 'go')
+source=("git+${url}")
+b2sums=('SKIP')
+
+# If project uses github releases:
+prepare() {
+ cd "$_pkgname"
+ git checkout $(curl -s https://api.github.com/repos/$_author/$_pkgname/releases | grep tag_name | cut -d '"' -f4 | head -n 1)
+}
+
+pkgver() {
+ cd "$_pkgname"
+ (set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$_pkgname"
+ export CGO_CPPFLAGS="$CPPFLAGS"
+ export CGO_CFLAGS="$CFLAGS"
+ export CGO_CXXFLAGS="$CXXFLAGS"
+ export CGO_LDFLAGS="$LDFLAGS"
+ export GOFLAGS="-v -buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ make secretservice
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm755 bin/build/docker-credential-secretservice "$pkgdir/usr/bin/docker-credential-secretservice"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+post_install() {
+ echo "Remember to add the following to $HOME/.docker/config.json :"
+ echo '
+{
+ "credsStore": "osxkeychain"
+}
+'
+ echo "Refer to https://docs.docker.com/engine/reference/commandline/login/#credentials-store for more information"
+}
+
+# vim:set ts=2 sw=2 et: