aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIdo Rosen2015-10-06 07:47:17 -0400
committerIdo Rosen2015-10-06 07:47:17 -0400
commitbf2163b5aaa72fa46172d7499885c48e79e56eb7 (patch)
treef5d46087290da350b8de81c6da966342fcdfdc12
parent7d7be7d664f250ee5f7bae2d5f8e723a126ea1b6 (diff)
downloadaur-bf2163b5aaa72fa46172d7499885c48e79e56eb7.tar.gz
Updates from PRs.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
-rw-r--r--docker.service4
3 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f5a899f498d..60ab0607e104 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = docker-git
pkgdesc = Pack, ship and run any application as a lightweight container
- pkgver = 1.7.0.dev.14855.c158cdb
+ pkgver = 1.9.0.dev.16580.729c9a9
pkgrel = 1
epoch = 1
url = https://github.com/dotcloud/docker
diff --git a/PKGBUILD b/PKGBUILD
index 7346e4fbc771..80390d6fe586 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# $Id$
+# $Id: bfc54885f6617a81b35939f12f0a9f02199bb6d8 $
# Maintainer: Ido Rosen <ido@kernel.org>
# Contributor: Sébastien "Seblu" Luttringer
# Contributor: Marcel Wysocki <maci@satgnu.net>
# Contributor: Daniel YC Lin <dlin.tw@gmail>
# Contributor: Joerg <joerg@higgsboson.tk>
+# Contributor: Vincent Aranega <vincent.aranega@gmail.com>
#
# NOTE: To request changes to this package, please submit a pull request
# to the GitHub repository at https://github.com/ido/packages-archlinux
@@ -11,12 +12,12 @@
#
pkgname=docker-git
-pkgver=1.7.0.dev.14855.c158cdb
+pkgver=1.9.0.dev.16580.729c9a9
pkgrel=1
epoch=1
pkgdesc='Pack, ship and run any application as a lightweight container'
arch=(i686 'x86_64')
-url="https://github.com/dotcloud/docker"
+url="https://github.com/docker/docker"
license=('Apache')
depends=('bridge-utils' 'iproute2' 'device-mapper' 'sqlite' 'systemd')
makedepends=('git' 'go' 'btrfs-progs' 'go-md2man')
@@ -25,7 +26,7 @@ provides=('docker')
conflicts=('docker')
# don't strip binaries! A sha1 is used to check binary consistency.
options=('!strip')
-source=("git+https://github.com/dotcloud/docker.git"
+source=("git+https://github.com/docker/docker.git"
'docker.service'
'docker.install'
docker.conf
@@ -57,7 +58,7 @@ build() {
cd docker
export AUTO_GOPATH=1
./hack/make.sh dynbinary
- for i in docs/man/*.md; do
+ for i in man/*.md; do
go-md2man -in "$i" -out "${i%.md}"
done
}
@@ -80,8 +81,8 @@ package() {
# systemd
install -Dm644 "$srcdir/docker.service" "$pkgdir/usr/lib/systemd/system/docker.service"
install -Dm644 "$srcdir/docker.conf" "$pkgdir/etc/sysctl.d/docker.conf"
-
- cd docs/man
+
+ cd man
for section in 1 5; do
for i in *.$section; do
install -Dm644 "$i" "$pkgdir/usr/share/man/man$section/$i"
diff --git a/docker.service b/docker.service
index b96d19ddb064..80d772d6d17e 100644
--- a/docker.service
+++ b/docker.service
@@ -1,11 +1,11 @@
[Unit]
Description=Docker Application Container Engine
-Documentation=http://docs.docker.io
+Documentation=http://docs.docker.com
After=network.target
[Service]
ExecStartPre=/usr/bin/mount --make-rprivate /
-ExecStart=/usr/bin/docker -d
+ExecStart=/usr/bin/docker daemon
[Install]
WantedBy=multi-user.target