aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Fordham2017-10-15 13:29:06 +1100
committerChris Fordham2017-10-15 13:29:06 +1100
commite0e75d0e1c8e2f04dba2428b2d478223e8f50e6b (patch)
tree49951a5a3143fc0e66abb38ef6c14e2f812b5d4e
parentc57d9d02fa5f66068995adbd4e3583acaf9b6a52 (diff)
downloadaur-e0e75d0e1c8e2f04dba2428b2d478223e8f50e6b.tar.gz
Include packaging tini.
-rw-r--r--PKGBUILD19
1 files changed, 17 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c03af3b4605..8082ce932745 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,7 +21,7 @@ arch=('i686' 'x86_64')
url="https://github.com/docker/docker"
license=('Apache License Version 2.0')
depends=('bridge-utils' 'iproute2' 'device-mapper' 'sqlite' 'systemd')
-makedepends=('glibc' 'git' 'go' 'btrfs-progs' 'go-md2man' 'apparmor-libapparmor')
+makedepends=('glibc' 'git' 'go' 'btrfs-progs' 'go-md2man' 'apparmor-libapparmor' 'cmake')
provides=('docker')
conflicts=('docker' 'containerd' 'containerd-git' 'runc' 'runc-git')
replaces=('docker' 'containerd' 'containerd-git' 'runc' 'runc-git')
@@ -33,12 +33,14 @@ source=('moby::git+https://github.com/moby/moby.git'
'containerd::git+https://github.com/containerd/containerd.git'
'runc::git+https://github.com/opencontainers/runc.git'
'libnetwork::git+https://github.com/docker/libnetwork.git'
+ 'tini::git+https://github.com/krallin/tini.git'
'docker.install')
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'1a8e60447794b3c4f87a2272cc9f144f')
pkgver() {
@@ -72,6 +74,10 @@ prepare() {
msg2 "checking out libnetwork ($LIBNETWORK_COMMIT)"
git checkout -q "$LIBNETWORK_COMMIT"
popd >/dev/null
+ pushd "$srcdir/tini" >/dev/null
+ msg2 "checking out tini ($TINI_COMMIT)"
+ git checkout -q "$TINI_COMMIT"
+ popd >/dev/null
# apply any patches for runc
pushd "$srcdir/runc" >/dev/null
@@ -110,7 +116,6 @@ build() {
ln -sf "$srcdir/libnetwork" "$GOPATH/src/github.com/docker/"
pushd "$GOPATH/src/github.com/docker/libnetwork" >/dev/null
: "${PROXY_LDFLAGS:=-linkmode=external}"
-
go build -ldflags="$PROXY_LDFLAGS" -o ./bin/docker-proxy 'github.com/docker/libnetwork/cmd/proxy'
popd >/dev/null
@@ -134,6 +139,13 @@ build() {
export AUTO_GOPATH=1
./hack/make.sh dynbinary
popd >/dev/null
+
+ # tini (docker-init)
+ msg2 'building docker-init'
+ pushd tini >/dev/null
+ cmake .
+ make tini-static
+ popd >/dev/null
}
# TODO: complete tests for all
@@ -165,6 +177,9 @@ package() {
msg2 'docker cli binary'
install -Dm755 "$GOPATH/src/github.com/docker/cli/build/docker" "$pkgdir/usr/bin/docker"
+ msg2 'docker-init binary'
+ install -Dm755 "$srcdir/tini/tini-static" "$pkgdir/usr/bin/docker-init"
+
msg2 'additional softlinks'
# symlink containerd/run (nice integration...)
ln -s containerd "$pkgdir/usr/bin/docker-containerd"