aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel YC Lin2014-06-29 13:23:58 +0800
committerDaniel YC Lin2014-06-29 13:23:58 +0800
commitf583721667d1501b283a310239d19d31031b9ca8 (patch)
tree8b7d9da2bc13c9dd0f246028d7590113f1f6941a
parentea33e26d78395405b7634fb94aea8beca429c01d (diff)
downloadaur-f583721667d1501b283a310239d19d31031b9ca8.tar.gz
Support i686 unofficially. Added sample sysctl.conf
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD47
-rw-r--r--docker-nocheck.patch17
-rw-r--r--docker.conf2
4 files changed, 57 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af5ae9d37767..5dfd9b7dc843 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,35 @@
pkgbase = docker-git
pkgdesc = Pack, ship and run any application as a lightweight container
- pkgver = 0.7.0.dev.4905.a8e99d9
+ pkgver = 1.0.1.dev.9202.4a9dc8d
pkgrel = 1
epoch = 1
url = https://github.com/dotcloud/docker
install = docker.install
+ arch = i686
arch = x86_64
license = Apache
makedepends = git
makedepends = go
- makedepends = device-mapper
+ makedepends = btrfs-progs
depends = bridge-utils
depends = iproute2
depends = device-mapper
- depends = lxc
depends = sqlite
depends = systemd
- depends = btrfs-progs
provides = docker
conflicts = docker
- conflicts = lxc-docker
- replaces = lxc-docker-git
options = !strip
+ backup = etc/sysctl.d/docker.conf
source = git+https://github.com/dotcloud/docker.git
source = docker.service
source = docker.install
+ source = docker-nocheck.patch
+ source = docker.conf
md5sums = SKIP
md5sums = 3f7ccab915fb1942f06e18946c2811d2
md5sums = 1a8e60447794b3c4f87a2272cc9f144f
+ md5sums = 1f8bc27c86d30e2d849102de4b7af1c9
+ md5sums = 9bce988683771fb8262197f2d8196202
pkgname = docker-git
diff --git a/PKGBUILD b/PKGBUILD
index 199e16bfbfc8..fd513688b101 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,6 +2,7 @@
# Maintainer: Ido Rosen <ido@kernel.org>
# Contributor: Sébastien "Seblu" Luttringer
# Contributor: Marcel Wysocki <maci@satgnu.net>
+# Contributor: Daniel YC Lin <dlin.tw@gmail>
#
# NOTE: To request changes to this package, please submit a pull request
# to the GitHub repository at https://github.com/ido/packages-archlinux
@@ -9,29 +10,34 @@
#
pkgname=docker-git
-pkgver=0.7.0.dev.4905.a8e99d9
+pkgver=1.0.1.dev.9202.4a9dc8d
pkgrel=1
epoch=1
pkgdesc='Pack, ship and run any application as a lightweight container'
-arch=('x86_64')
+arch=(i686 'x86_64')
url="https://github.com/dotcloud/docker"
license=('Apache')
-depends=('bridge-utils' 'iproute2' 'device-mapper' 'lxc' 'sqlite' 'systemd' 'btrfs-progs')
-makedepends=('git' 'go' 'device-mapper')
+depends=('bridge-utils' 'iproute2' 'device-mapper' 'sqlite' 'systemd')
+makedepends=('git' 'go' 'btrfs-progs')
+backup=(etc/sysctl.d/docker.conf)
provides=('docker')
-conflicts=('docker' 'lxc-docker')
-replaces=('lxc-docker-git')
+conflicts=('docker')
# don't strip binaries! A sha1 is used to check binary consistency.
options=('!strip')
source=("git+https://github.com/dotcloud/docker.git"
'docker.service'
- 'docker.install')
+ 'docker.install'
+ docker-nocheck.patch
+ docker.conf
+ )
md5sums=('SKIP'
'3f7ccab915fb1942f06e18946c2811d2'
- '1a8e60447794b3c4f87a2272cc9f144f')
+ '1a8e60447794b3c4f87a2272cc9f144f'
+ '1f8bc27c86d30e2d849102de4b7af1c9'
+ '9bce988683771fb8262197f2d8196202')
install='docker.install'
# magic harcoded path
-_magic=src/github.com/dotcloud
+#_magic=src/github.com/dotcloud
pkgver() {
cd "${srcdir}/docker"
@@ -40,24 +46,30 @@ pkgver() {
}
prepare() {
- mkdir -p "$_magic"
- ln -sfn "../../../docker" "$_magic/docker"
+ #mkdir -p "$_magic"
+ #ln -sfn "../../../docker" "$_magic/docker"
+ #cd "$_magic/docker"
+ cd docker
+ [ $arch = i686 ] && patch -p0 -i $srcdir/docker-nocheck.patch
}
build() {
- cd "$_magic/docker"
- export GOPATH="$srcdir:$srcdir/$_magic/docker/vendor"
+ #cd "$_magic/docker"
+ #export GOPATH="$srcdir:$srcdir/$_magic/docker/vendor"
+ cd docker
+ export AUTO_GOPATH=1
./hack/make.sh dynbinary
}
-check() {
- cd "$_magic/docker"
+#check() {
+ #cd "$_magic/docker"
# Will be added upstream soon
#./hack/make.sh dyntest
-}
+#}
package() {
- cd "$_magic/docker"
+ #cd "$_magic/docker"
+ cd docker
_dockerver="$(cat VERSION)"
install -Dm755 "bundles/$_dockerver/dynbinary/docker-$_dockerver" "$pkgdir/usr/bin/docker"
install -Dm755 "bundles/$_dockerver/dynbinary/dockerinit-$_dockerver" "$pkgdir/usr/lib/docker/dockerinit"
@@ -66,6 +78,7 @@ package() {
install -Dm644 "contrib/completion/zsh/_docker" "$pkgdir/usr/share/zsh/site-functions/_docker"
# systemd
install -Dm644 "$srcdir/docker.service" "$pkgdir/usr/lib/systemd/system/docker.service"
+ install -Dm644 "$srcdir/docker.conf" "$pkgdir/etc/sysctl.d/docker.conf"
}
# vim:set ts=2 sw=2 et:
diff --git a/docker-nocheck.patch b/docker-nocheck.patch
new file mode 100644
index 000000000000..bb6ac8fc3a37
--- /dev/null
+++ b/docker-nocheck.patch
@@ -0,0 +1,17 @@
+--- docker/docker.go.orig 2014-06-28 08:46:43.261485969 +0800
++++ docker/docker.go 2014-06-28 08:48:33.424222468 +0800
+@@ -263,9 +263,11 @@
+
+ func checkKernelAndArch() error {
+ // Check for unsupported architectures
+- if runtime.GOARCH != "amd64" {
+- return fmt.Errorf("The Docker runtime currently only supports amd64 (not %s). This will change in the future. Aborting.", runtime.GOARCH)
+- }
++ /*
++ if runtime.GOARCH != "amd64" {
++ return fmt.Errorf("The Docker runtime currently only supports amd64 (not %s). This will change in the future. Aborting.", runtime.GOARCH)
++ }
++ */
+ // Check for unsupported kernel versions
+ // FIXME: it would be cleaner to not test for specific versions, but rather
+ // test for specific functionalities.
diff --git a/docker.conf b/docker.conf
new file mode 100644
index 000000000000..8e6edb580118
--- /dev/null
+++ b/docker.conf
@@ -0,0 +1,2 @@
+## disable ALL packet forwarding (not a router, disable it) (default)
+#net.ipv4.ip_forward = 0