summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlukaszimmermann2018-09-13 16:03:34 +0200
committerlukaszimmermann2018-09-13 16:03:34 +0200
commit819b02228ce18b0100ca8b4bade15ab4affd8a33 (patch)
tree4f52f91ee2f3a33735d23829dd83b06ec2915105
downloadaur-819b02228ce18b0100ca8b4bade15ab4affd8a33.tar.gz
Upstream release 0.3.1
-rw-r--r--.SRCINFO22
-rw-r--r--ChangeLog5
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD52
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95ef60e77566
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = docker-ls
+ pkgdesc = Tools for browsing and manipulating docker registries
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/mayflower/docker-ls
+ changelog = ChangeLog
+ arch = x86_64
+ license = MIT
+ makedepends = fakeroot
+ makedepends = git
+ makedepends = gcc
+ makedepends = go
+ options = strip
+ options = !staticlibs
+ options = !emptydirs
+ source = https://github.com/mayflower/docker-ls/archive/v0.3.1.tar.gz
+ source = LICENSE
+ sha256sums = da40737b5e8bb5c1d4ee14c90ffa419ac7f9e7687618fe4dc020e786f61ea88a
+ sha256sums = 36f5440582577e61065f48b6fc26e2dd563ef2eb11a04255fed3bf47d138ca9e
+
+pkgname = docker-ls
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..0ae580603d54
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,5 @@
+2018-09-13 Lukas Zimmermann <luk.zim91 at gmail dot com>
+
+ * 0.3.1-1:
+ Initial release of upstream
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..6e34f46d2322
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2016 Christian Speckner, Mayflower GmbH <christian.speckner@mayflower.de>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e95bf92e487
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Lukas Zimmermann <luk.zim91 at gmail dot com>
+
+pkgname=docker-ls
+pkgver=0.3.1
+pkgrel=1
+pkgdesc='Tools for browsing and manipulating docker registries'
+url='https://github.com/mayflower/docker-ls'
+license=('MIT')
+arch=('x86_64')
+makedepends=('fakeroot' 'git' 'gcc' 'go')
+options=('strip' '!staticlibs' '!emptydirs')
+changelog=ChangeLog
+
+source=("https://github.com/mayflower/${pkgname}/archive/v${pkgver}.tar.gz"
+ 'LICENSE')
+sha256sums=('da40737b5e8bb5c1d4ee14c90ffa419ac7f9e7687618fe4dc020e786f61ea88a'
+ '36f5440582577e61065f48b6fc26e2dd563ef2eb11a04255fed3bf47d138ca9e')
+
+# Custom variables
+_os=linux
+_arch=amd64
+_release=release
+
+build() {
+ # Remove GOPATH
+ rm -rf "${srcdir}/go" && mkdir -p "${srcdir}/go"
+
+ # Get all the dependencies for the command line tools
+ cd "${srcdir}/${pkgname}-${pkgver}/cli/docker-ls"
+ GOPATH="${srcdir}/go" go get -v -t -d
+ cd "${srcdir}/${pkgname}-${pkgver}/cli/docker-rm"
+ GOPATH="${srcdir}/go" go get -v -t -d
+
+ # Test and build the necessary library
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ rm -rf "${_release}" && mkdir -p "${_release}/${_os}_${_arch}"
+ GOPATH="${srcdir}/go" go test github.com/mayflower/docker-ls/lib/...
+ GOPATH="${srcdir}/go" go generate github.com/mayflower/docker-ls/lib/...
+
+ # Build the executables for the AMD64 platform
+ GOPATH="${srcdir}/go" CGO_ENABLED=0 GOOS="${_os}" GOARM=5 GOARCH="${_arch}" go build -o "${_release}/${_os}_${_arch}/docker-ls" github.com/mayflower/docker-ls/cli/docker-ls
+ GOPATH="${srcdir}/go" CGO_ENABLED=0 GOOS="${_os}" GOARM=5 GOARCH="${_arch}" go build -o "${_release}/${_os}_${_arch}/docker-rm" github.com/mayflower/docker-ls/cli/docker-rm
+}
+
+package() {
+
+ install -D -m755 "${pkgname}-${pkgver}/${_release}/${_os}_${_arch}/docker-ls" "${pkgdir}/usr/bin/docker-ls"
+ install -D -m755 "${pkgname}-${pkgver}/${_release}/${_os}_${_arch}/docker-rm" "${pkgdir}/usr/bin/docker-rm"
+ install -D -m644 "${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=4 sw=4 et: