summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Henrie2023-05-01 14:32:36 -0600
committerAlex Henrie2023-05-01 14:32:36 -0600
commit37d61202830b6f702b33a77eb7a65241c33880da (patch)
treecf2e408b2eac246efb57f25116d4e8fa116e545a
downloadaur-37d61202830b6f702b33a77eb7a65241c33880da.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b0fc5eaba5f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = docker-lvm-plugin-git
+ pkgdesc = Docker volume driver for LVM volumes
+ pkgver = v1.0.r14.d45273f
+ pkgrel = 1
+ url = https://github.com/containers/docker-lvm-plugin
+ arch = x86_64
+ license = GPL3
+ makedepends = go
+ makedepends = go-md2man
+ provides = docker-lvm-plugin
+ conflicts = docker-lvm-plugin
+ source = git+https://github.com/containers/docker-lvm-plugin
+ sha256sums = SKIP
+
+pkgname = docker-lvm-plugin-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc49bc72f2a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Alex Henrie <alexhenrie24@gmail.com>
+pkgname=docker-lvm-plugin-git
+pkgver=v1.0.r14.d45273f
+pkgrel=1
+pkgdesc='Docker volume driver for LVM volumes'
+arch=('x86_64')
+url='https://github.com/containers/docker-lvm-plugin'
+license=('GPL3')
+makedepends=('go' 'go-md2man')
+provides=('docker-lvm-plugin')
+conflicts=('docker-lvm-plugin')
+source=('git+https://github.com/containers/docker-lvm-plugin')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/docker-lvm-plugin"
+ printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd docker-lvm-plugin
+ export GO111MODULE=on
+ make
+}
+
+package() {
+ cd docker-lvm-plugin
+ make DESTDIR="$pkgdir/" install
+}