summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGore Liu2017-11-24 17:30:29 +0800
committerGore Liu2017-11-24 17:30:29 +0800
commit2f41223969647c08729e8aa6227dc6584395248e (patch)
tree7b0acdd4d15ef94ea8f68f580e9ab90e96d6e3d6
parent240c9061625db6280202bd938d1ec3f321d84449 (diff)
downloadaur-2f41223969647c08729e8aa6227dc6584395248e.tar.gz
Add systemctl3.py
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59138c0e763a..461ce8f18dbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Mon Aug 21 06:54:37 UTC 2017
+# Fri Nov 24 09:29:55 UTC 2017
pkgbase = docker-systemctl-replacement-git
pkgdesc = docker systemctl replacement
- pkgver = 239.f1093a1
+ pkgver = 516.610695a
pkgrel = 1
url = https://github.com/gdraheim/docker-systemctl-replacement
arch = any
license = GPL
- depends = python2
+ optdepends = python2: systemctl.py
+ optdepends = python3: systemctl3.py
source = docker-systemctl-replacement::git+https://github.com/gdraheim/docker-systemctl-replacement
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 031f80c08241..65d6fa76f99d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=docker-systemctl-replacement-git
_pkgname=docker-systemctl-replacement
-pkgver=239.f1093a1
+pkgver=516.610695a
pkgrel=1
pkgdesc="docker systemctl replacement"
url='https://github.com/gdraheim/docker-systemctl-replacement'
arch=('any')
license=('GPL')
-depends=('python2')
+optdepends=('python2: systemctl.py' 'python3: systemctl3.py')
source=("${_pkgname}::git+https://github.com/gdraheim/docker-systemctl-replacement")
sha512sums=('SKIP')
@@ -25,4 +25,5 @@ build() {
package() {
cd "${srcdir}/${_pkgname}"
install -Dm755 "files/docker/systemctl.py" "${pkgdir}/usr/bin/systemctl.py"
+ install -Dm755 "files/docker/systemctl3.py" "${pkgdir}/usr/bin/systemctl3.py"
}