summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorElrondo462019-09-14 08:47:43 +0200
committerElrondo462019-09-14 08:47:43 +0200
commitfe2f64bb06f8147f3427bba49177a0b185bc9030 (patch)
tree22d517eb38878e2f5775bc0f36c491d0df3cdca3
parent0b78144298de38ecdf6e8e03893e6f2e11c513a3 (diff)
downloadaur-fe2f64bb06f8147f3427bba49177a0b185bc9030.tar.gz
Sources no more in AUR
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--docker-userspace.service34
-rw-r--r--subgid1
-rw-r--r--subuid1
5 files changed, 9 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf660797cbd4..c488a85c0cc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
pkgbase = docker-userspace
pkgdesc = Docker in Username Space better isolation and security in case of file conflict you have to do it manually
- pkgver = 1.0
+ pkgver = 1.1
pkgrel = 1
url = https://www.tuxnvape.fr/
install = docker-userspace.install
arch = x86_64
license = GPL3
depends = docker
- source = subuid
- source = subgid
- source = docker-userspace.service
- sha256sums = 1eea5693d1ab5ad1d39440085ccea344b54da3a3a1826c91d9153b305d648c14
- sha256sums = 1eea5693d1ab5ad1d39440085ccea344b54da3a3a1826c91d9153b305d648c14
- sha256sums = d1e98c9c250c5f7b42e4f824ecdca45fab557f6cce1bc00ce3c7cbc6aea998fa
+ source = https://github.com/Elrondo46/docker-userspace/archive/1.1.tar.gz
+ sha256sums = SKIP
pkgname = docker-userspace
diff --git a/PKGBUILD b/PKGBUILD
index d1d867f5267a..156ef941eaf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Elrondo46 TuxnVape <elrond94@hotmail.com>
pkgname=docker-userspace
-pkgver=1.0
+pkgver=1.1
pkgrel=1
pkgdesc="Docker in Username Space better isolation and security in case of file conflict you have to do it manually"
arch=('x86_64')
@@ -9,16 +9,11 @@ license=('GPL3')
url="https://www.tuxnvape.fr/"
depends=("docker")
install=docker-userspace.install
-source=("subuid"
- "subgid"
- "docker-userspace.service")
-
-sha256sums=('1eea5693d1ab5ad1d39440085ccea344b54da3a3a1826c91d9153b305d648c14'
- '1eea5693d1ab5ad1d39440085ccea344b54da3a3a1826c91d9153b305d648c14'
- 'd1e98c9c250c5f7b42e4f824ecdca45fab557f6cce1bc00ce3c7cbc6aea998fa')
+source=("https://github.com/Elrondo46/docker-userspace/archive/1.1.tar.gz")
+sha256sums=('fa3b8b548c55fc366f41624ed17d9443a108471ccb93f86eaad5089942a01a19')
package() {
- install -Dm644 "subuid" "${pkgdir}/etc/subuid"
- install -Dm644 "subgid" "${pkgdir}/etc/subgid"
- install -Dm644 "docker-userspace.service" "${pkgdir}/usr/lib/systemd/system/docker-userspace.service"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/subuid" "${pkgdir}/etc/subuid"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/subgid" "${pkgdir}/etc/subgid"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/docker-userspace.service" "${pkgdir}/usr/lib/systemd/system/docker-userspace.service"
}
diff --git a/docker-userspace.service b/docker-userspace.service
deleted file mode 100644
index f167b10140bd..000000000000
--- a/docker-userspace.service
+++ /dev/null
@@ -1,34 +0,0 @@
-[Unit]
-Description=Docker Application Container Engine in Userspace Name Mode
-Documentation=https://docs.docker.com
-After=network-online.target docker.socket firewalld.service
-Wants=network-online.target
-Requires=docker.socket
-
-[Service]
-Type=notify
-# the default is not to use systemd for cgroups because the delegate issues still
-# exists and systemd currently does not support the cgroup feature set required
-# for containers run by docker
-ExecStart=/usr/bin/dockerd --userns-remap=default
-ExecReload=/bin/kill -s HUP $MAINPID
-LimitNOFILE=1048576
-# Having non-zero Limit*s causes performance problems due to accounting overhead
-# in the kernel. We recommend using cgroups to do container-local accounting.
-LimitNPROC=infinity
-LimitCORE=infinity
-# Uncomment TasksMax if your systemd version supports it.
-# Only systemd 226 and above support this version.
-#TasksMax=infinity
-TimeoutStartSec=0
-# set delegate yes so that systemd does not reset the cgroups of docker containers
-Delegate=yes
-# kill only the docker process, not all processes in the cgroup
-KillMode=process
-# restart the docker process if it exits prematurely
-Restart=on-failure
-StartLimitBurst=3
-StartLimitInterval=60s
-
-[Install]
-WantedBy=multi-user.target
diff --git a/subgid b/subgid
deleted file mode 100644
index cdee85b2cc45..000000000000
--- a/subgid
+++ /dev/null
@@ -1 +0,0 @@
-dockremap:110000:65536
diff --git a/subuid b/subuid
deleted file mode 100644
index cdee85b2cc45..000000000000
--- a/subuid
+++ /dev/null
@@ -1 +0,0 @@
-dockremap:110000:65536