summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVan-ess02017-11-08 15:11:37 +0300
committerVan-ess02017-11-08 15:11:37 +0300
commit4ecb0f5b4bd630a0d7671e7bc7501c3ac757b060 (patch)
treef9f8e5b43dfc59494c2c2824edecc1487c777cad
downloadaur-4ecb0f5b4bd630a0d7671e7bc7501c3ac757b060.tar.gz
Initial commit 1.3.0-1
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD23
-rw-r--r--dockstation.install19
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db9ebe113abe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+pkgbase = dockstation
+ pkgdesc = Working with Docker has never been so easy and convenient.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/DockStation/dockstation
+ install = dockstation.install
+ arch = x86_64
+ license = proprietary
+ depends = alsa-lib
+ depends = atk
+ depends = cairo
+ depends = dbus
+ depends = desktop-file-utils
+ depends = electron
+ depends = expat
+ depends = fontconfig
+ depends = freetype2
+ depends = gcc-libs
+ depends = gconf
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk2
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk2
+ depends = libcups
+ depends = libnotify
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxrandr
+ depends = libxrender
+ depends = libxss
+ depends = libxtst
+ depends = nspr
+ depends = nss
+ depends = pango
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://github.com/DockStation/dockstation/releases/download/v1.3.0/dockstation_1.3.0_amd64.deb
+ sha512sums_x86_64 = 182db4742b8d9147f2a812dcacd6f4a1bf9fed5430a3cf607f4900d0b757df8ac044e1a8e775aa22fdb9332c776d6308a9966feb837882ec6cec689c8ffd8def
+
+pkgname = dockstation
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdeb9005ff77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Van-ess0 <van-ess0@mail.ru>
+pkgname=dockstation
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Working with Docker has never been so easy and convenient."
+arch=('x86_64')
+url="https://github.com/DockStation/dockstation"
+license=('proprietary')
+groups=('')
+depends=('alsa-lib' 'atk' 'cairo' 'dbus' 'desktop-file-utils' 'electron' 'expat' 'fontconfig' 'freetype2' 'gcc-libs' 'gconf' 'gdk-pixbuf2' 'glib2' 'gtk2' 'hicolor-icon-theme' 'libappindicator-gtk2' 'libcups' 'libnotify' 'libx11' 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxrandr' 'libxrender' 'libxss' 'libxtst' 'nspr' 'nss' 'pango')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://github.com/DockStation/dockstation/releases/download/v1.3.0/dockstation_1.3.0_amd64.deb")
+sha512sums_x86_64=('182db4742b8d9147f2a812dcacd6f4a1bf9fed5430a3cf607f4900d0b757df8ac044e1a8e775aa22fdb9332c776d6308a9966feb837882ec6cec689c8ffd8def')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ install -D -m644 "${pkgdir}/opt/DockStation/LICENSES.chromium.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}
diff --git a/dockstation.install b/dockstation.install
new file mode 100644
index 000000000000..37ea5f9622d9
--- /dev/null
+++ b/dockstation.install
@@ -0,0 +1,19 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Link to the binary
+ ln -sf '/opt/DockStation/dockstation' '/usr/bin/dockstation'
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+
+ # Delete the link to the binary
+ rm -f '/usr/bin/dockstation'
+ update-desktop-database -q
+}