summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2021-09-27 10:19:42 +0200
committerLucki2021-09-27 10:19:42 +0200
commit472f8efc878330d5826cd10096f20cee17716199 (patch)
tree613bf837de53930475e9241f57af3327aa25e348
parent199c3fd4b12713d50f774a58568c2c4627aec395 (diff)
downloadaur-472f8efc878330d5826cd10096f20cee17716199.tar.gz
upgpkg: docspell 0.27.0-1
upstream release
-rw-r--r--.CHANGELOG47
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD7
3 files changed, 55 insertions, 9 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index 89fcd1ca7bef..ded01a5be606 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,5 +1,52 @@
# Changelog
+## v0.27.0
+
+*Sep 23, 2021*
+
+- Allow external authentication providers via [OpenID
+ Connect](https://openid.net/connect). Now you can integrate Docspell
+ into your SSO solution. Using keycloak, for example (or other such
+ tools) users can be maintained elsewhere, like in an LDAP directory.
+ (#489)
+- Adds two-factor authentication using TOTPs. If you don't want to
+ setup an external authentication provider (which is another tool to
+ maintain), you can use the builtin TOTP support to have two-factor
+ authentication. (#762)
+- Improvements when querying documents (#1040)
+- Changed the underlying code for storing and loading files. This is a
+ preparation to allow different storage backends for files in the
+ future (maybe the filesystem or s3). (#1080)
+- The license has changed from GPLv3+ to AGPLv3+ (#1078)
+- Fixes a bug in the "check for updates" task that was added in the
+ last release (#1068)
+- Reduces the length of the startup command, which makes tools like
+ `ps` much more readable and allows now to start docspell on Windows
+ (untested, though ;-)) (#1062)
+- Fixes merging items, where sent mails were not copied to the target
+ item. (#1055)
+- Fixes and improves deleting users. Now all their data is also
+ removed and it is shown what that would be. (#1060)
+
+### Rest API Changes
+
+- The `login` routes now won't return a session token when 2FA is
+ enabled for an account. The returned token must be used to provide
+ the TOTP in order to finalize login.
+- Added `open/auth/two-factor` endpoint to provide the TOTP for login
+- Added `open/auth/openid/{providerId}[/resume]` endpoints to initiate
+ authentication via an external provider
+- Added `sec/user/{username}/deleteData` to retrieve a summary of data
+ that would be deleted with that user
+- Added `sec/user/otp/*` endpoints to manage the TOTP for an account
+- Added `admin/user/otp/reserOTP` to reset the 2FA setup for any user
+
+### Configuration Changes
+
+- Restserver: Added a section to configure external authentication
+ provider
+
+
## v0.26.0
*Aug 28, 2021*
diff --git a/.SRCINFO b/.SRCINFO
index 8066f5832dfc..ceb18beaba9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = docspell
pkgdesc = Assists in organizing your piles of documents, resulting from scanners, e-mails and other sources with miminal effort.
- pkgver = 0.26.0
+ pkgver = 0.27.0
pkgrel = 1
url = https://docspell.org/
changelog = .CHANGELOG
arch = any
groups = docspell
license = GPL3
- source = docspell-0.26.0-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.26.0/docspell-restserver-0.26.0.zip
- source = docspell-0.26.0-joex.zip::https://github.com/eikek/docspell/releases/download/v0.26.0/docspell-joex-0.26.0.zip
+ source = docspell-0.27.0-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.27.0/docspell-restserver-0.27.0.zip
+ source = docspell-0.27.0-joex.zip::https://github.com/eikek/docspell/releases/download/v0.27.0/docspell-joex-0.27.0.zip
source = docspell-joex.sh
source = docspell-restserver.sh
source = docspell-joex.service
source = docspell-restserver.service
source = docspell.sysusers
source = docspell.tmpfiles
- sha512sums = 4f0a60030e3e0866f86df18b412c3fa1ba82881d206b7d342c0773a1c8e065e67345b666961428ffe8539d92f69aeb6be5be880e761c257855fbec3e56c982b1
- sha512sums = c0cff7fbce104c8c4f2ebc301b8b65e185b41d2b7b4112169354bba113fea4b3b4971918ff0c346c44d741b51a72fbef61593a2ea54be1263fe6657f6a854db2
+ sha512sums = 870bc59d2e7c703a7038fbd5a95ab6930937e0b97c13105204a74d3aef1cf28c303454201c4c04ca1feaede4109d3bf1982dd720bb0b8fa0bf81d74ed575d0b9
+ sha512sums = c4527c3d36b6d1caa090d3352848f0cba4cd319e106d5cb215f22d8585490c08b9a92e9f7231c944efdd3369ea2a689fc498a4727d1b5d59344f717bfb51fbde
sha512sums = 6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093
sha512sums = 0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8
sha512sums = c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004
diff --git a/PKGBUILD b/PKGBUILD
index 6e05e1b3d6f3..53f4e918da1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=(
'docspell-restserver'
# 'firefox-extension-docspell'
)
-pkgver=0.26.0
+pkgver=0.27.0
pkgrel=1
changelog=.CHANGELOG
arch=('any')
@@ -24,9 +24,8 @@ source=("$pkgbase-$pkgver-restserver.zip::https://github.com/eikek/$pkgbase/rele
"${pkgname[1]}.service"
"$pkgbase.sysusers"
"$pkgbase.tmpfiles")
-sha512sums=('4f0a60030e3e0866f86df18b412c3fa1ba82881d206b7d342c0773a1c8e065e67345b666961428ffe8539d92f69aeb6be5be880e761c257855fbec3e56c982b1'
- 'c0cff7fbce104c8c4f2ebc301b8b65e185b41d2b7b4112169354bba113fea4b3b4971918ff0c346c44d741b51a72fbef61593a2ea54be1263fe6657f6a854db2'
- # '5b71747e2f7758df8dff5a4abfe57ff8e1d302ad5b70fb576696b44d2ef358ebc34f797793a868441d6c8c1990294dc97b42697a37c16f1fc784c3196205b7f4'
+sha512sums=('870bc59d2e7c703a7038fbd5a95ab6930937e0b97c13105204a74d3aef1cf28c303454201c4c04ca1feaede4109d3bf1982dd720bb0b8fa0bf81d74ed575d0b9'
+ 'c4527c3d36b6d1caa090d3352848f0cba4cd319e106d5cb215f22d8585490c08b9a92e9f7231c944efdd3369ea2a689fc498a4727d1b5d59344f717bfb51fbde'
'6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093'
'0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8'
'c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004'