summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucki2022-11-15 16:37:06 +0100
committerLucki2022-11-15 16:37:06 +0100
commit8b3d14b29364803ab8754a3d2a305716bb07003c (patch)
tree24105f2cb724cf5f936f38582b8958df35923451
parent4ae1372ba27d2320e7cc035fefbf28c32c7f191a (diff)
downloadaur-8b3d14b29364803ab8754a3d2a305716bb07003c.tar.gz
upgpkg: docspell 0.39.0-1
upstream release
-rw-r--r--.CHANGELOG136
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
3 files changed, 144 insertions, 8 deletions
diff --git a/.CHANGELOG b/.CHANGELOG
index c410ece8db36..3099cd03eac3 100644
--- a/.CHANGELOG
+++ b/.CHANGELOG
@@ -1,5 +1,141 @@
# Changelog
+## v0.39.0
+
+*Nov 7th, 2022*
+
+- Allow to set extracted content (#1775) You can now fix OCRed text
+ this way.
+- Improve handling mixes of OIDC and local accounts (#1827). It is now
+ possible to use the same account locally and via OIDC.
+- Add Estonian language (#1646)
+- Updated docker images to new alpine and openjdk, fixing #1736
+ (#1713) by @jberggg and @eikek
+ - drops support for arm7 (#1719)
+ - introduces `weasyprint` as an alternative to `wkhtmltopdf` for
+ converting html files to pdf
+- Fix docspell's query to remove `attach.count`. It has been removed a
+ while ago, but the query language didn't reflect it (#1758)
+- Fix search for linked items (#1808)
+- Fix item selection after merging (#1809)
+- Internal changes to how a collective is referenced as a preparation
+ for #585 (#1686)
+- Update H2 to 2.1.x, incompatible to the previous used version
+ (#1690)
+
+### PLEASE NOTE
+
+The database structure changed substantially in this release. Please
+make sure to create a backup of your database **before** attempting
+the upgrade!
+
+### Docker Users
+
+There are two major changes for docker users: First ARM7 support has
+been dropped, because it was too much work to maintain alongside the
+other architectures. Second the images have been updated to the latest
+alpine linux, which requires to sacrifice using `wkhtmltopdf` as a
+tool to convert HTML to PDF (often used for processing emails).
+
+The joex image doesn't have the `wkhtmltopdf` binary anymore, because
+it is not available for alpine linux. Instead `weasyprint` has been
+added. Docspell by default still uses `wkhtmltopdf`, because I found
+it has better results. But you can now switch to `weasyprint` and if
+you use the provided docker images you _have to_.
+
+There is a new config that you need to set - when using environment
+variables:
+
+```
+DOCSPELL_JOEX_CONVERT_HTML__CONVERTER=weasyprint
+```
+
+Just add it to the env variables in the `docker-compose.yml`. If you
+use a config file, add this to it:
+
+```
+docspell.joex {
+ convert.html-converter = "weasyprint"
+}
+```
+
+### File Backends
+
+The internal change on how collectives are now referenced requires to
+adopt the files accordingly. If you have your files in the database,
+all is being migrated automatically on first start.
+
+For other file backends, the files must be migrated manually. The
+difference is that from now on a collective is referenced by a unique
+number and not by its name anymore. You can look at the table
+`collective` to see which number was assigned to a collective and then
+
+- for a filebackend, simply move the folder with a collective name to
+ its corresponding number
+- for s3 backend the same must happen, using some s3 client (maybe
+ [this
+ one](https://min.io/docs/minio/linux/reference/minio-mc/mc-mv.html))
+
+### H2
+
+If you use H2 as a database, there are some manual steps required. H2
+was bumped from 1.4.x to 2.1.x and the new version cannot read the
+database files of the old version.
+
+Additionally, one of the changesets for H2 used a now illegal syntax
+and had to be changed. This will lead to checksum mismatch errors when
+starting up.
+
+Creating and restoring a dump, the script `tools/h2-util.sh` can be
+used. The H2 version can be specified with an environment variable
+`H2_VERSION` to easily create a dump in one version and restore in
+another.
+
+To fix the changeset, you could simply run this sed command on the
+dump before restoring:
+
+```
+sed -i 's,175554607,-276220379,g' docspell-dump-h2.sql
+```
+
+But this could potentially change not only the checksum, but other
+things in the dump. It is not very likely, though. A more safe
+alternative is to use a text editor and find the correct place to
+change or just set `database-schema.repair-schema = true` in the
+config file or use the env variables
+
+```
+DOCSPELL_SERVER_BACKEND_DATABASE__SCHEMA_REPAIR__SCHEMA=true
+```
+
+and startup only the restserver one time to have the checksum fixed.
+Another safe variant is to run this update statement on your h2
+database:
+
+```sql
+UPDATE flyway_schema_history set checksum = -276220379 WHERE version = '1.9.3';
+```
+
+
+### Rest API changes
+
+- Adds apis for retrieving and setting extracted text at
+ `/sec/attachment/{id}/extracted-text`
+
+
+### Configuration Changes
+
+Restserver:
+- Adds `auth.on-account-source-conflict` to decide what to do if an
+ account exists locally and at some OIDC provider
+
+Joex:
+- Adds a new system command for `weasyprint` an alternative to
+ `wkhtmltopdf`
+- Adds the setting `convert.html-converter` to set which to use
+ (default stays on `wkhtmltopdf`)
+
+
## v0.38.0
*Jul 09, 2022*
diff --git a/.SRCINFO b/.SRCINFO
index 2158c2fe1696..f198164a65f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = docspell
pkgdesc = Assists in organizing your piles of documents, resulting from scanners, e-mails and other sources with miminal effort.
- pkgver = 0.38.0
+ pkgver = 0.39.0
pkgrel = 1
url = https://docspell.org/
changelog = .CHANGELOG
arch = any
groups = docspell
license = GPL3
- source = docspell-0.38.0-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.38.0/docspell-restserver-0.38.0.zip
- source = docspell-0.38.0-joex.zip::https://github.com/eikek/docspell/releases/download/v0.38.0/docspell-joex-0.38.0.zip
+ source = docspell-0.39.0-restserver.zip::https://github.com/eikek/docspell/releases/download/v0.39.0/docspell-restserver-0.39.0.zip
+ source = docspell-0.39.0-joex.zip::https://github.com/eikek/docspell/releases/download/v0.39.0/docspell-joex-0.39.0.zip
source = docspell-joex.sh
source = docspell-restserver.sh
source = docspell-joex.service
source = docspell-restserver.service
source = docspell.sysusers
source = docspell.tmpfiles
- sha512sums = daed88d44e3ded96e1279d8616baa002369e23a5e681f47252a4d2a09b69f9f37424b32c793f27a1b3e6dfd5ec2b0e96948476689dd6d9b771e954f356e88038
- sha512sums = 8dc931ae31c9a02956323d83b8a6002bb1137bcb6566b546473b74fce6d3c622fc2dc1821ede1817e488b7466f5bc10a28a6739437b1b136a7b4eb466912cc55
+ sha512sums = cce3530bbd9a374d9c29f7b27e38adfb3e5e264279fc5eb828ba16e1c580c7ae615aad45182ce71bbfc808af33aa63a0985b6a2576fa9c31cd7fa790e5542c86
+ sha512sums = c3b759b4b00dbbbd15aa0e7f2fcc10e769b7d23fd36844982764e978509d8d9e4c3fd304a7d55ebf469eb38b7740237a2cff38095d965a6356f1308731183bb9
sha512sums = 6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093
sha512sums = 0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8
sha512sums = c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004
diff --git a/PKGBUILD b/PKGBUILD
index 38cd8179cdd3..ebed25fea9d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname=(
'docspell-joex'
'docspell-restserver'
)
-pkgver=0.38.0
+pkgver=0.39.0
pkgrel=1
changelog=.CHANGELOG
arch=('any')
@@ -23,8 +23,8 @@ source=("$pkgbase-$pkgver-restserver.zip::https://github.com/eikek/$pkgbase/rele
"${pkgname[1]}.service"
"$pkgbase.sysusers"
"$pkgbase.tmpfiles")
-sha512sums=('daed88d44e3ded96e1279d8616baa002369e23a5e681f47252a4d2a09b69f9f37424b32c793f27a1b3e6dfd5ec2b0e96948476689dd6d9b771e954f356e88038'
- '8dc931ae31c9a02956323d83b8a6002bb1137bcb6566b546473b74fce6d3c622fc2dc1821ede1817e488b7466f5bc10a28a6739437b1b136a7b4eb466912cc55'
+sha512sums=('cce3530bbd9a374d9c29f7b27e38adfb3e5e264279fc5eb828ba16e1c580c7ae615aad45182ce71bbfc808af33aa63a0985b6a2576fa9c31cd7fa790e5542c86'
+ 'c3b759b4b00dbbbd15aa0e7f2fcc10e769b7d23fd36844982764e978509d8d9e4c3fd304a7d55ebf469eb38b7740237a2cff38095d965a6356f1308731183bb9'
'6ab8b24eb76f02b68e4fa4194b8771ef4f57c8375b34bf7bf914563528e347ea127beb5547e432910911d4fd15982cccdd1df50aeb76058129b909824ce49093'
'0b8b08f47f1cb46a3bfc16df4b0574cebfb4a851562d134fcba3c4bf80fb011443499a549c3a04480456c048346d09f36fbcbc9d792810001c9c8b370d3926a8'
'c1a7a9cb942413d0febb083554a15ded0ead5c7124624f0ec5fe43d3bc73a1637f89bc27f7b6e0bbdbd0d886799e5331beb5f45f476db70b69ae17c0d803f004'